1

We have Magento EE 1.14. Admin was working fine till last two days its speed dropped dramatically. Frontend is not affected. Also no changes in code or server configuration. here is my attempt to fix the problem but nothing worked:

  • Log cleaning is properly configured
  • removed two unused extensions. but no improvement
  • tried to disable non-critical extensions to see if speed will improve but also not luck.
  • I can NOT use REDIS cache at this time. but configured new server which is using REDIS cache and move to it next month.
  • sometimes backend will gain speed for few minutes
  • I enabled profilers the source of the delay is mage ( screenshot attached ). enter image description here

here are my question:

  • Is there anyway to know the exact reason for Mage delay ?
  • do I have other test i can use to identify the cause of delay ?

Thanks in advance,

  • sorry for resuming this old post but my magento 1.9 is suffering this issue on latest time. Could I know what extension has to be disabled to grow up the backend performances? Thanks a lot – Pier Feb 19 at 17:52
  • Unfortunately I am no longer with that company and I dont remember the extension name. but I do remember that I had to disable extensions one by one and test till I found the bad one. – Zeedia Feb 19 at 22:11
0

"Is there anyway to know the exact reason for Mage delay? do I have other test i can use to identify the cause of delay?" Ultimately, yes. Easily, probably not.

First of all, see if you can replicate this issue in a staging or development environment. This will allow you to experiment without risking a negative impact to the production site.

It sounds like you are on the right track. You need to slowly eliminate possible sources of error, for example disabling extensions as you did. Other things I would try:

  • ensure codebase is at same version as production

  • ensure database is the same, as closely as possible: same stores, same products and categories, same system configuration

  • just disable your caches so you are not tricking yourself. Later, after you have resolved the issue, you can enable the caches in order to improve performance.

  • clear magento cache: rm -rf var/cache var/full_page_cache

  • reindex from the command line: php shell/indexer.php reindexall

After these basic cleaning steps, go through the workflow during which you experience slowness. If you still do not experience the slowness, then you can be reasonably confident that the issue is related to the server configuration: mysql, apache, DNS, redis, CDN, anything external to the Magento application. If you do experience the slowness, then that is a sign that something is amiss with your instance of the Magento application: a code issue, and extension, incorrect admin configuration, something of the nature.

I hope that helps. Unfortunately, with such a general error, I can't provide much more assistance than these basic troubleshooting steps to try and determine the source: Magento itself? or an environment issue?

  • I found the problem it was one of the extension that no longer supported. i had to disable it and everything went fine :) – Zeedia Dec 15 '16 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.