1

I installed Magento in XAMPP, and the installation is fully complete. However, when I go to Fontend and Backend, the loading is very long, also all the thumbnails crash. I tried install again, but the same problem is still here.

I find out a error on console, it seems no any file in the directory: enter image description here

Here is my backend, all the thumbnail crash and the loading is unstopptable. enter image description here

How can I solve the infinitely-loading and the thumbnail problem?

2
  • Did you run static deploy command? Dec 15 '16 at 5:41
  • No... I am trying now.. Dec 15 '16 at 6:02
2

run command ./bin/magento setup:static-content:deploy

or

php -f magento setup:static-content:deploy

from console

0
0

When you installed magento 2 the admin links wont work. In order to make the links to work. Goto magento root folder app/etc/di.xml then comment this line

<item name="view_preprocessed" xsi:type="object">Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink</item>

and paste this code

<item name="default" xsi:type="object">Magento\Framework\App\View\Asset\MaterializationStrategy\Copy</item>

save and check links will work. Also do reindex using

php bin/magento indexer:reindex

To display thumbnails do static content deployment using

php bin/magento setup:static-content:deploy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.