6

I am getting a 50 second server response time for a category page.

When processing, the following is shown in top:

4312 www-data 20 0 488280 146704 41816 R 99.7 1.8 1:11.54 php-fpm7.0

I have x-debug enabled with php7.0-fpm and nginx. Developer mode is on and I am developing so I am not looking for a turn on production mode answer. I am using magento 2.1.2. I am also using a redis-server cache backend. I am also on php 7.0.14 on ubuntu 16.04.

After enabling xdebug remote debugging and adding a breakpoint the average time to get a server response is a whopping 3 minutes. That is messed up. I am using atom with the php-debug package for atom to debug.

I am also on an SSD, so read and writes should be fast right?

After running dstat -D hda these are the results:

disk usage read and writes

Update: After disabling js merging and minification

After disabling js merging and minification as well as css merging server response improved to about 7 to 8 seconds. Thanks @Konstantin, it is now bearable.

9
  • disable css/js merging (stores > configuration > advanced > developer) and report back Dec 13 '16 at 13:38
  • It worked, gone from 30sec/1min down to about 7 - 8 seconds. Much better. Are there any other tips you can give?
    – stephen
    Dec 13 '16 at 13:52
  • There is another problem...when atom hits the breakpoint it keeps processing for about 20 seconds.
    – stephen
    Dec 13 '16 at 13:53
  • what happens if you set xdebug.remote_autostart = 0. then use debug cookie/param to enable disable xdebug. at the moment it is probably connecting on every request. taken from here - stackoverflow.com/questions/17736304/… Dec 13 '16 at 14:04
  • With each step over atom burns CPU at 100% for about 20 seconds,
    – stephen
    Dec 14 '16 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.