Magento ver.

Added the 'Ground' shipping option in the Admin under the DEFAULT configuration scope but it does not appear on the front end. It only shows the following options on the front end:

 Home Delivery $17.35
 Express Saver $22.72
 Standard Overnight $33.29
 Priority Overnight $35.15

I cleared all Cache after adding this option and re-indexed but it did not help.

I had to set the Residential Delivery to NO in order to get the Ground shipping option to appear on the front end (as per here - 'Ground' not appearing in FedEx shipping method magento ) Why is that? And does it have any negative affects for us? (we do deliver to residential AND business addresses)

We actually need both - ground AND home delivery. How can I accomplish that??


1 Answer 1


With the Fedex Shipping Method as is, you can not do it.

I wish there was an extension that did an address check first and then pulled the rates for the address being shipped to - Residential or Commercial. I have not found one.

A possible hack is to set the Residential flag to TRUE if a company name is entered. This is not 100%. Small businesses run out our residential addresses will be quoted commercial rates and if a big company fails to enter the company name, it will be charged residential. However it is better than nothing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.