2

I have installed Magento 1.9.3.1, but I have a problem.

I can't find many 1.9.3.1 themes and I don't like the themes I found.

So, can I use a theme made for an older version of Magento, like 1.9.2.4, for example?

How much will it take until the themes will be upgraded to 1.9.3.1?

1

I disagree with other people's answer.

In general, you won't see a difference when you install a theme developped for 1.9.2.4 on 1.9.3 BUT there was some theme changes in 1.9.3 that thus, will be missing from your theme and you need to take into consideration:

  • app/design/frontend/base/default/layout/catalog.xml : specially with the new way Magento handles the product options (see here: https://magento.stackexchange.com/a/141375/2380)
  • app/design/frontend/base/default/layout/review.xml : same as above
  • app/design/frontend/base/default/layout/sendfriend.xml : same again
  • app/design/frontend/base/default/template/checkout/onepage/payment.phtml : this one is important as it affects the payment step during the checkout.
  • app/design/frontend/base/default/template/customer/form/edit.phtml : this one is important too as the change in 1.9.3 allows the customers to change their password
  • app/design/frontend/base/default/template/paypal/express/review.phtml : not 100% sure how bad it would be without the change in this file.
  • app/design/frontend/base/default/template/paypal/hss/js.phtml : I reckon PayPal related templates could potentially affect payments via PayPal in some way.
  • app/design/frontend/base/default/template/sales/guest/form.phtml : minor change
  • app/design/frontend/base/default/template/sales/widget/guest/form.phtml : same here

On top of that, some files in the skin folder have changed too:

  • skin/frontend/base/default/js/bundle.js : affects the price selection for the bundle products
  • skin/frontend/base/default/js/checkout/review.js : minor change
  • skin/frontend/base/default/js/giftmessage.js : minor change
  • skin/frontend/base/default/js/ie6.js : minor change
  • skin/frontend/base/default/js/msrp.js : minor change
  • skin/frontend/base/default/js/opcheckout.js : lot of changes here, which could potentially affect the checkout.

To summarize, you can install a 1.9.2.4 theme on Magento 1.9.3 but depending on how deeply customized it is, you may face issues related to the list above.

Important note

It does not affect 1.9.3.1 but in some cases, using an theme for an older Magento version will result in some security breach not being fixed and thus will make your store vulnerable to attacks.

-1

Yes, you can use any theme which supports 1.9.x version of magento. There are not big differences in all of them.

  • Thank you. How much will it take until the themes will be upgraded to 1.9.3.1? – Vlad Dec 7 '16 at 9:36
  • It depends on developers of themes. I think there are not many changes that you can even rectify. So don't worry you can use those theme. – Gaurav Agrawal Dec 7 '16 at 9:44
  • I disagree, there are some differences and sometimes it's security related. – Raphael at Digital Pianism Dec 7 '16 at 10:12
  • I have used old version themes in my projects, but I didn't find any problem in them. What I think is Security updates will not effect the theme structure or any of the functionalities. – Gaurav Agrawal Dec 7 '16 at 10:20
-1

Yes. You can use theme generally there is not big difference and you can also check difference from release notes to make sure old version theme will not create issue.

You can see release notes for all magento 1 version here http://devdocs.magento.com/guides/m1x/ce19-ee114/ce1.9_release-notes.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.