1

I have a language pack installed. That's giving my shop the language it needs. only when transactional mails are send out some parts are not translated. I decided to add them myself in a nl_NL.csv file. But unfortunately that's not applied. So How to deal with this and where to have the csv file loacated? I know I could change the templates as well, but that's taking a lot of time and the parts I need are general "subject" phrases.

Like these:

"Your %store_name order confirmation","Uw Bestelling van %store_name"
"Your %store_name order has shipped","Uw Bestelling is verstuurd %store_name"
"Invoice for your %store_name order","Uw Factuur von %store_name"
"Your Order <span class=""no-link"">#%increment_id</span>","Uw bestelling <span class=""no-link"">#%increment_id</span>"

This is where I have the csv file now:

enter image description here

This is what the mail looks like now:

enter image description here

1

You have to keep your translate csv file inside your theme root i18n folder.

Currently You have placed csv file at wrong folder.

Your csv file path,

app/design/frontend/{Vendorname}/{themename}/i18n/nl_NL.csv file.

You cant keep csv file inside your theme module folder.

Run command,

php bin/magento setup:static-content:deploy en_US nl_NL

Clear cache and remove var folder.

  • I tried this but still not working. My mail looks like this now some parts are not translated. have tried with the file in: app/design/frontend/{Vendorname}/{themename}/i18n/nl_NL.csv app/code/i18n/nl_NL.csv but not applied? Also run: hp bin/magento setup:static-content:deploy en_US nl_NL and emptied the cache/ static. – mr_typo3 Dec 7 '16 at 9:32
  • Have you keep csv file inside root i18n folder – Rakesh Jesadiya Dec 7 '16 at 9:34
  • What do you mean by "root" in app/ or in /var/www/html/ ? – mr_typo3 Dec 7 '16 at 9:39
  • your theme root app/design/frontend/{Vendor}/{themename}/i18n – Rakesh Jesadiya Dec 7 '16 at 9:40
  • I moved it from module into: app/design/frontend/{Vendor}/{themename}/i18n but that did not work. – mr_typo3 Dec 7 '16 at 9:45
0

Solved this issue by removing the language pack which was installed. And install an other better maintained language pack found through github.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.