0

I am using a community extension but it wont let me upload/install the extension. It says it supports 5.3 to 5.6.0 and I am running 5.6.23 so I figured its safe to install it on my system.

So question is, how can I bypass such checks?

  • It wont let me install the extension because of that. – kudN008 Dec 2 '16 at 14:55
  • Have you checked the code inside the extension? There should be a PHP check hardcoded in it – Julien Lachal Dec 2 '16 at 14:56
  • could be but i dont want to be editing extensions. its a third party extension – kudN008 Dec 2 '16 at 15:00
1

(Unable to comment, so adding my thoughts as an answer)

Your best bet would be to contact the developer of the module and see if the module 1) will run on php 5.6.23 and 2) if so, can they update the module to allow it to install. In my experience, if it's a well maintained module, the developers tend to respond to such requests/questions in a reasonable time.

There very well could be a reason why it only supports up to 5.6.0 other than the module just not being updated. Even if you can figure out a way to bypass the check with or without modifying the code in the extension, it's possible other problems arise due to the version discrepancy.

| improve this answer | |
-1

This is fixed.

There is a --force flag when you use mage cli.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.