0

I've updated the EcomDev_Varnish module to it's latest version and it seems I've gotten everything properly running, but as a test I tried following command: php ecomdev-varnish.php cache:ban -v b2b_int/customer/account/login/ from the /var/www/src/shell directory and it give the following error:

PHP Fatal error:  Class 'ride\library\varnish\VarnishPool' not found in /var/www/src/app/code/community/EcomDev/Varnish/Model/Connector.php on line 76
PHP Stack trace:
PHP   1. {main}() /var/www/src/shell/ecomdev-varnish.php:0
PHP   2. EcomDev_Varnish_Shell->run() /var/www/src/shell/ecomdev-varnish.php:238
PHP   3. EcomDev_Varnish_Shell->runCacheBan() /var/www/src/shell/ecomdev-varnish.php:136
PHP   4. EcomDev_Varnish_Model_Connector->getVarnishPool() /var/www/src/shell/ecomdev-varnish.php:208
PHP   5. EcomDev_Varnish_Model_Connector->_initVarnishPool() /var/www/src/app/code/community/EcomDev/Varnish/Model/Connector.php:62

The file in question is: /src/app/code/community/EcomDev/Varnish/Model/Connector.php (I have not edited any of the files).

The line in question is: $this->pool = new VarnishPool(); (protected function _initVarnishPool).

I've tried to edit this line to ... = new ride\library\varnish\VarnishPool();, as I've found in answers to similar questions, also no succes (I've done this without the () at the end, but no difference).

Has anyone come across this before or knows how to fix this? Maybe I've done something wrong during installation/update, but this, however possible, seems unlikely since everything else appears to work.

Many thanks

0

I've figured out the problem, apparently I did goof up during installation. I installed the vendor in the wrong directory, so the autoload couldn't be reached and it couldn't handle the namespaces properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.