I'm trying to add google analytics for my client. I've added the UA-# to Stores > Configuration > Sales > Google API. I see that it's been added but I need to confirm with Google Search Console. They state: "The Google Analytics tracking code on your site is in the wrong location. You can verify site ownership with the asynchronous snippet placed in the section of your home page." All I'm finding is information that seems to be outdated on how to add the actual Google code to the website. I can't find where to add the code to the HEAD HTML. Please help.

  • What version of magento are you using?
    – SR_Magento
    Commented Dec 1, 2016 at 20:23

2 Answers 2


go to System->configuration->Design tab

insert your meta and script tag in Miscellaneous Scripts.

This will be included before head closing tag in page HTML.

  • Thank you for replying, but under System, there is no configuration tab visible. There is a configuration tab under Stores > Configuration > General > Design. And when I get there, there is no Miscellaneous Scripts. Just an area titled "Search Engine Robots". I can't find the Miscellaneous Scripts anywhere. Thank you.
    – Mike
    Commented Dec 2, 2016 at 13:52
  • Mike seems you don't have the full access to your store and you are not an adminstrator and somebody limited your access, you should be an adminstrator to change settings, I advise to talk to your developer to do it for you.
    – Nickool
    Commented Dec 6, 2016 at 19:27
  • It is now Content > Design > Configuration go to edit on your website theme and expand HTML Head and enter the script in Scripts and Style Sheets. Then flush cache.
    – Eddie
    Commented May 15, 2020 at 3:24

insert your meta and script tag in

Content > Design > Configuration

then your website -> edit

html head -> script and styles

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.