In my project, when a user creates an account they get the mail. But after making an order neither the customer nor the admin gets the mail. I found many solutions but that's all for Magento 1.9 or below. I am using Magento 2. I need a solution with or without using cron job. Can anyone help?

  • Have you checked Configure -> Sales Emails enable or not?
    – Dev
    Dec 1, 2016 at 9:45
  • yes i checked it.
    – Anu
    Dec 1, 2016 at 9:47
  • Is this issues you are facing on local machine or on server?
    – Dev
    Dec 1, 2016 at 9:49
  • on local machine
    – Anu
    Dec 1, 2016 at 9:50
  • which version are you using? Magento 2.x.x? Dec 1, 2016 at 10:10

3 Answers 3


If you don't want to use Cron then just disable Email Async Setting from Admin.

Admin -> Configuration -> Sales -> Sales Emails -> General Settings -> Asynchronous sending -> Disable.

It should work for you If your server is configured for sending Email.


In sales emails configuration enable the order email sending and email templates as shown below image.

enter image description here

  • i already made these changes.
    – Anu
    Dec 1, 2016 at 9:54

You might not able to send any email from local, because you have not configure SMTP on local server (Wamp/Xampp). You can used below free extension & input your gmail smtp details.


This will resolve your problem.

  • but what if i'm using it on server? . Actually i don't want to use extensions. is there is other solutions without using extensions?
    – Anu
    Dec 1, 2016 at 10:02
  • you can remove this extension on server, Magento will auto send emails if your server has email server configure.
    – Dev
    Dec 1, 2016 at 10:03
  • but in server also i face this issue:(
    – Anu
    Dec 1, 2016 at 10:04
  • You can check this question for configuration smtp on local magento.stackexchange.com/questions/11438/…
    – Dev
    Dec 1, 2016 at 10:07
  • it also about using extensions. when i run it on the server also it doesn't send mail.
    – Anu
    Dec 1, 2016 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.