0

When i visit my localhost:8080 i get the standard page like so:

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.


How come i'm not landing on the magento install page for EE?

I've tried changing my config.xml and local.xml files numerous times, but i guess i'm confused on what it should be.

Here is my config.xml file

        <default_setup>
            <connection>
                <host>127.0.0.1:8080</host>
                <username/>
                <password/>
                <dbname>magento</dbname>
                <model>mysql4</model>
                <initStatements>SET NAMES utf8</initStatements>
                <type>pdo_mysql</type>
                <active>0</active>
                <persistent>0</persistent>
            </connection>
        </default_setup>

my db name is magento. this is correct.

local.xml

<config>
    <global>
        <install>
            <date>{{date}}</date>
        </install>
        <crypt>
            <key>{{key}}</key>
        </crypt>
        <disable_local_modules>false</disable_local_modules>
        <resources>
            <db>
                <table_prefix>{{db_prefix}}</table_prefix>
            </db>
            <default_setup>
                <connection>
                    <host>{{localhost}}</host>
                    <username>{{user}}</username>
                    <password>{{**********}}</password>
                    <dbname>{{magento}}</dbname>
                    <initStatements>{{db_init_statemants}}</initStatements>
                    <model>{{db_model}}</model>
                    <type>{{db_type}}</type>
                    <pdoType>{{db_pdo_type}}</pdoType>
                    <active>1</active>
                </connection>
            </default_setup>
        </resources>
        <session_save>{{session_save}}</session_save>
    </global>
    <admin>
        <routers>
            <adminhtml>
                <args>
                    <frontName>{{admin_frontname}}</frontName>
                </args>
            </adminhtml>
        </routers>
    </admin>
</config>

my windows host file:

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
    127.0.0.1       localhost
#   ::1             localhost

when i'm in vagrant ssh and i go to etc/hosts

Here is what my file looks like:

vagrant@precise32:/etc$ cat hosts
127.0.0.1       localhost
127.0.1.1       precise32

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

The page i want to run magento off is this: localhost:8080

How do i edit the above to fix that... sorry for all the questions.

2

First of all ,did you created your virtual host on apache (on vagrant) ? You have to set the documentRoot to your app in your virtual host. Basically u don't need to create your local.xml for an install, because this file will be created during the Magento install.

  • I did not do this yet. Completely forgot because it's not something I do all that often. Would you please be kind enough to refresh my memory on where and how to do this task. Thank you. – Supplement Dec 1 '16 at 17:49
  • Yes, I'm using apache. – Supplement Dec 1 '16 at 17:50
  • in your /etc/hosts you have to write your.vagrant.ip your.project.dev : example 192.168.33.10 myawesomeproject.dev you can retrieve all this information in your vagrant file. – Sony Dec 4 '16 at 23:39
  • Make sure your virtual host is configured, on your vagrant. Make a vagrant ssh , and go to the folder /etc/apache/sites-available/ you should have your file config there... Make sure to enable your site after with cmd a2ensite :) – Sony Dec 4 '16 at 23:47
  • Sorry to ask just a couple more questions @Sony. Inside my etc/apache2/sites-available I have these two files. vagrant@precise32:/etc/apache2/sites-available$ ls default default-ssl <<<< do i need to edit the default or create a new file? – Supplement Dec 14 '16 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.