0

I have an extension to replace the default Magento search, but I have always this message no product results. On the previous Magento version was work fine, after upgrade is not work anymore.

I add in this function public function prepareProductCollection($collection) this code before return:

Mage::log($collection->getSelectSQL(1), false, 'search.log', true);
Mage::log((array)Mage::getConfig()->getNode()->global->models->catalogsearch, false, 'search.log', true);

to see what search return but I don't know how to read the exact issue.

Here is the results for search.log

2016-11-28T14:19:17+00:00 EMERG (): SELECT DISTINCT `e`.*, MAX(  ((product_name.value LIKE '%test%')*1 + (product_name.value RLIKE '[[:<:]]tests[[:>:]]') + (product_name.value LIKE '%test%')*1 + (bss_index.tag LIKE '%test%')*1 + (bss_index.categories LIKE '%test%')*1 + (`e`.sku LIKE '%test%')*1 + (`e`.sku = 'test')*1 + 0) + search_result.relevance  ) AS `relevance`, `price_index`.`price`, `price_index`.`tax_class_id`, `price_index`.`final_price`, IF(price_index.tier_price IS NOT NULL, LEAST(price_index.min_price, price_index.tier_price), price_index.min_price) AS `minimal_price`, `price_index`.`min_price`, `price_index`.`max_price`, `price_index`.`tier_price`, `cat_index`.`position` AS `cat_index_position` FROM `catalog_product_entity` AS `e`
 INNER JOIN `catalogsearch_result` AS `search_result` ON search_result.product_id=e.entity_id AND search_result.query_id='1'
 LEFT JOIN `catalog_product_entity_varchar` AS `product_name` ON product_name.entity_id=e.entity_id AND product_name.attribute_id = '71'
 LEFT JOIN `bss_index` ON bss_index.product_id = e.entity_id
 INNER JOIN `catalog_product_index_price` AS `price_index` ON price_index.entity_id = e.entity_id AND price_index.website_id = '1' AND price_index.customer_group_id = 0
 INNER JOIN `catalog_category_product_index` AS `cat_index` ON cat_index.product_id=e.entity_id AND cat_index.store_id='1' AND cat_index.visibility IN(3, 4) AND cat_index.category_id = '2' GROUP BY `e`.`entity_id`
2016-11-28T14:19:17+00:00 EMERG (): Array
(
    [class] => Mage_CatalogSearch_Model
    [resourceModel] => catalogsearch_resource
    [rewrite] => Mage_Core_Model_Config_Element Object
        (
            [fulltext] => TBT_Bss_Model_CatalogSearch_Fulltext
        )

)

What I need to do or there is something that I can check?

Thank you

1

It seems like it's an incompatibility issue with the newest version of Magento. I'm also using BSS and facing the same problem. After searching "CatalogSearch" in the diff's for Magento's recent upgrades (1.9.3 and 1.9.3.1), you can notice that they made several changes to the core search functionality, which probably introduced incompatibility issues to BSS.

Also, if I disable the BSS extension, search works again. In my case disabling the BSS Engine at the BSS Settings page didn't work, that's why I had to disable the extension.

UPDATE

As Hbit said, BSS just released a new version which fixes the issue. You should be able to download it from your BSS Account: http://www.betterstoresearch.com/customer/account/login/

0

You need to update to the latest Better Store Search release which features a fix to deal with the search related changes in Magento 1.9.3.0 and 1.9.3.1.

I did this yesterday and it worked. At the time of writing the latest BSS release is v1.2.1.0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.