I have started working on Magento 2.1.2 and require to update few modules and files but I am not able to update .phtml files.

I have create theme with the name of theme and doing all by in theme folder:

  1. vendor-name : Abc (NameSpace)
  2. theme-name‌​ : developer (theme_name)

ie: I tried with another .phtml override. Here its:

  1. Copy from /vendor/magento/module-wishlist/view/frontend/templates/link‌​.phtml to /app/design/frontend/Abc/developer/module-wis‌​hlist/view/frontend/‌​templates/link.phtml (there is no other file in module-wishlist directory in my theme)
  2. php bin/magento setup:static-content:deploy
  3. php bin/magento cache:flush
  4. Also manually deleted cache from PUB(except .htaccess) and VAR/view_preprocessed

    But in debug mode this .phtml file still diplaying from /vendor/magento/module-wishlist/view/frontend/templates/link‌​.phtml

It may be duplicate for few question but i didnt get my answer by following below links:

  1. Override Magento 2 phtml Files?
  2. Magento 2 Override minicart.phtml template? (My Comments are here)
  3. http://devdocs.magento.com/guides/v2.1/frontend-dev-guide/themes/theme-inherit.html
  4. How to override .phtml files in Magento 2
  5. Override PHTML files in Magento 2.1.0

It should be very simple to override .phtml files, modules as well but I am not able to do this. It may be issue of Magento version 2.1.2? I apologies again if it's duplicate but I left with no option. I must be missing something very important.

  • You have to create first theme and after you can override file Nov 28, 2016 at 10:13
  • I did same and qestion is also updated.
    – Jarnail S
    Nov 28, 2016 at 10:18
  • Please give me path of your theme Nov 28, 2016 at 10:19
  • /app/design/frontend/Abc/developer and theme is working fine.
    – Jarnail S
    Nov 28, 2016 at 10:21
  • just to confirm you are checking same store ? where you activate your custom theme ? Nov 28, 2016 at 10:37

3 Answers 3


try running from the cli

php bin/magento setup:upgrade
php bin/magento cache:flush
  • Yes I did from CLI. but didnt work
    – Jarnail S
    Nov 28, 2016 at 11:07
  • before flushing the cache did you try a static-content:deploy?
    – JohnyWind
    Nov 28, 2016 at 11:14
  • or even try a compile command instead of deploy
    – JohnyWind
    Nov 28, 2016 at 11:15
  • I tried deploy only and flush after that
    – Jarnail S
    Nov 28, 2016 at 11:17

You have to just below folder inside your theme,

Create Magento_Wishlist folder,


Clear cache and check.

  • i already did the same and cleared the cache manully and from CLI too.
    – Jarnail S
    Nov 28, 2016 at 10:27
  • Have you checked your wishlist module is enable? Nov 28, 2016 at 10:33
  • yes, its enabled
    – Jarnail S
    Nov 28, 2016 at 10:34
  • 1
    May be you have to check for log file, above scenario is perfect for override any core file into module file. Nov 28, 2016 at 10:48
  • May be you have used module-wis‌​hlist/view/frontend/‌​templates in your theme path you have to set only Magento_Wishlist/templates folder Nov 28, 2016 at 11:16

You have used like this,

Copy from




Magento_Wishlist instead of module-wis‌​hlist.


don't need to use view/frontend after Magento_Wishlist.

  • thats already tried
    – Jarnail S
    Nov 28, 2016 at 10:28
  • have you recompile after this? Nov 28, 2016 at 10:56
  • Please check question under title "I tried with another .phtml override. Here its" . Kindly let me know if more need to do there?
    – Jarnail S
    Nov 28, 2016 at 11:02
  • have you tried with Magento_Wishlist this folder? Nov 28, 2016 at 11:04
  • yes its : /app/design/frontend/Abc/developer/module-wis‌​hlist/view/frontend/‌​templates/link.phtml
    – Jarnail S
    Nov 28, 2016 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.