1

I'm getting Unusual error on Admin.

In my local it's working fine. But on server when i try to select my newly created Attribute Set

domain.com/admin_ychhtn/catalog/product/reload/type/simple/store/0/popup/1/componentJson/1/prev_set_id/4/key/986e85ebbdfe1560684f97bc8e942e09d9f401ef6e3a87f501a5539ea2a6744d/?set=9&isAjax=true

Above AJAX URL Leads to 503 Service Unavailable. So it's not loading my Attributes.

I have checked in error log it says

a:4:{i:0;s:49:"Invalid UI Component element name: 'product_form'";i:1;s:3651:"#0 /var/www/html/magento/vendor/magento/framework/View/Element/UiComponentFactory.php(144): Magento\Ui\Model\Manager->prepareData('product_form')
#1 /var/www/html/magento/vendor/magento/framework/View/Layout/Generator/UiComponent.php(124): Magento\Framework\View\Element\UiComponentFactory->create('product_form', NULL, Array)
#2 /var/www/html/magento/vendor/magento/framework/View/Layout/Generator/UiComponent.php(93): Magento\Framework\View\Layout\Generator\UiComponent->generateComponent(Object(Magento\Framework\View\Layout\Data\Structure), 'product_form', Array, Object(Magento\Framework\View\Layout\Interceptor))
#3 /var/www/html/magento/vendor/magento/framework/View/Layout/GeneratorPool.php(86): Magento\Framework\View\Layout\Generator\UiComponent->process(Object(Magento\Framework\View\Layout\Reader\Context), Object(Magento\Framework\View\Layout\Generator\Context))
#4 /var/www/html/magento/vendor/magento/framework/View/Layout.php(327): Magento\Framework\View\Layout\GeneratorPool->process(Object(Magento\Framework\View\Layout\Reader\Context), Object(Magento\Framework\View\Layout\Generator\Context))
#5 /var/www/html/magento/var/generation/Magento/Framework/View/Layout/Interceptor.php(89): Magento\Framework\View\Layout->generateElements()
#6 /var/www/html/magento/vendor/magento/framework/View/Layout/Builder.php(129): Magento\Framework\View\Layout\Interceptor->generateElements()
#7 /var/www/html/magento/vendor/magento/framework/View/Page/Builder.php(55): Magento\Framework\View\Layout\Builder->generateLayoutBlocks()
#8 /var/www/html/magento/vendor/magento/framework/View/Layout/Builder.php(65): Magento\Framework\View\Page\Builder->generateLayoutBlocks()
#9 /var/www/html/magento/vendor/magento/framework/View/Page/Config.php(197): Magento\Framework\View\Layout\Builder->build()
#10 /var/www/html/magento/vendor/magento/framework/View/Page/Config.php(217): Magento\Framework\View\Page\Config->build()
#11 /var/www/html/magento/app/code/Amasty/AdminActionsLog/Observer/handleLayoutRenderBefore.php(36): Magento\Framework\View\Page\Config->getTitle()
#12 /var/www/html/magento/vendor/magento/framework/Event/Invoker/InvokerDefault.php(73): Amasty\AdminActionsLog\Observer\handleLayoutRenderBefore->execute(Object(Magento\Framework\Event\Observer))
#13 /var/www/html/magento/vendor/magento/framework/Event/Invoker/InvokerDefault.php(61): Magento\Framework\Event\Invoker\InvokerDefault->_callObserverMethod(Object(Amasty\AdminActionsLog\Observer\handleLayoutRenderBefore), Object(Magento\Framework\Event\Observer))
#14 /var/www/html/magento/vendor/magento/framework/Event/Manager.php(66): Magento\Framework\Event\Invoker\InvokerDefault->dispatch(Array, Object(Magento\Framework\Event\Observer))
#15 /var/www/html/magento/var/generation/Magento/Framework/Event/Manager/Proxy.php(95): Magento\Framework\Event\Manager->dispatch('layout_render_b...', Array)
#16 /var/www/html/magento/vendor/magento/framework/View/Result/Layout.php(166): Magento\Framework\Event\Manager\Proxy->dispatch('layout_render_b...')
#17 /var/www/html/magento/var/generation/Magento/Framework/View/Result/Layout/Interceptor.php(89): Magento\Framework\View\Result\Layout->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#18 /var/www/html/magento/vendor/magento/framework/App/Http.php(139): Magento\Framework\View\Result\Layout\Interceptor->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#19 /var/www/html/magento/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http->launch()
#20 /var/www/html/magento/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#21 {main}";s:3:"url";s:182:"/admin_ychhtn/catalog/product/reload/type/simple/store/0/popup/1/componentJson/1/prev_set_id/4/key/986e85ebbdfe1560684f97bc8e942e09d9f401ef6e3a87f501a5539ea2a6744d/?set=9&isAjax=true";s:11:"script_name";s:10:"/index.php";}

I cleared var/cache & var/generation folder as well. Still Issue.

magento\vendor\magento\module-catalog\Controller\Adminhtml\Product\Reload.php

Need to debug on above file How?

When i add Product Attribute is not loading, But when i do Update for Product at that time only it loads.

1

We had the same issue. Disabling the Amasty_AdminActionsLog fixed this for us.

3
  • You are absolutely right. By disabling that Module It Works Fine. Contacting Extension Provider to Solve Issue. Thanks a lot – Jackson Dec 9 '16 at 1:48
  • how to know which modules files is cause the error.. I also same problem "Invalid UI Component element name: '' – 55840 Dec 12 '18 at 9:38
  • @SatishVishwakarma Sorry for late reply, don't know if it's relevant anymore. In this case, you can see the Amasty module mentioned at #11 in the error log debug trace. However, if your issue doesn't come from this module, find the error log entry and look for the first line mentioning a non /vendor/ file path, as that will most likely be the custom code causing this error – Jangri Jan 22 '19 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.