4

I´ve install correctly the package Magento-CE-2.1.2_sample_data-2016-10-11-11-24-30.

I can see the test page LUMA perfectly. But when I try to enter on the admin page, I put the correct user and password and the message shows:

There has been an error processing your request Notice: Use of undefined constant CURLOPT_PROTOCOLS - assumed 'CURLOPT_PROTOCOLS' in /home/storage/4/28/79/a7consulting2/public_html/store/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php on line 73

I've installed the magento on the 'store' folder...

Could you help me?

4

You need to install php curl (apt-get install php5-curl or apt-get install php7.0-curl if you useung php7 ) and restart your web server for apache is service apache2 restart

0

It's likely your php version is messed up: your cli version and apache version (info.php output) could be different.

In my case: cli 7.1 vs php.info 7.0, and because my php curl extension is installed as version php7.1, I got the same error in a fresh Magento 2.2.6 installation. Disable 7.0 and enable 7.1 will fix the issue, assume that you also have php7.1-curl installed.

This doc tells you all the required php extensions as a system requirement, IMO for Magento 2.2.* use php7.1 encounters less issues than php7.0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.