0

I can't seem to get the Magmi version: 0.7.22 (just upgraded) to import multiple values into a multiselect attribute. Magento 1.9.3 (unless someone can show me magmi working in magento 2.x)

This is my source file

attribute_set|type|sku|testcolor|supplier|size default|Simple|2-ALN2320|"Red , Blue"|Flint|89 it loads the supplier & size fine.. But the testcolor is a multiselect type and it does not work.. I have tried to remove the spaces, same result.. I tried to use..

attribute_set|type|sku|testcolor:multiple:1|supplier|size default|Simple|2-ALN2320|"Red,Blue"|Flint|89 That also did not work I don't see any errors in progress.txt I have tired to change the multiselect delimiter to ; that also do not work. I have tired to just put ONE value in there, that did not work.. Dropdown, text attributes work just fine..

I am running out of options.

ANY idea on what I am missing?

1

If you have upgraded you will find Magento has changed attribute type for multi-select attributes from VARCHAR to TEXT, this was probably due limitations that existed with number of available attribute options when using VARCHAR

have you tried changing the attribute option labels in your spreadsheet to the corresponding database option IDs?

i would probably try that first and if not then you will need to edit the following file within (your-magmi-install-directory)/plugins/inc/ to include the field type change

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.