0

So a client came on board with a Magento site that hadn't been upgraded for years and were experiencing security issues. So we cleaned up their site and upgraded them to 1.9.2.4.

As I've been testing their system I've noticed that I cannot upload any new product images. All folder permissions are correct. When I try to upload the image it says "Upload complete" but the new image does not appear in the list. This affects new or current products.

So I did some digging. There is nothing in the server or Magento logs that would explain the issue. I went through the code step by step trying to figure out where it's falling down. So far I've discovered that the file is being uploaded to the /tmp directory. It is then correctly moved to the magento/media/tmp folder. After that nothing appears to happen.

Has anybody had this issue before? Any ideas what is going wrong?

NB. This doesn't appear to affect any other image upload such as wysiwyg.

Thanks

3
  • ithink its issue of permission so upload magento_cleanup.php and run that file to assign permission. Nov 22, 2016 at 12:20
  • Who is your host? Are you running the SUPEE-8788 patch? Nov 22, 2016 at 13:25
  • Permissions are all correct, checked manually and with magento_cleanup.php. SUPEE-8788 is installed. It's a dedicated server.
    – Doyley
    Nov 22, 2016 at 14:54

2 Answers 2

0

Magento has deprecated the old Flash uploader in favor of a new HTML 5 uploader in patch SUPEE-8788/version 1.9.3.1. Due to the old uploader being insecure, I have seen some top Magento hosts blocking it (and rightly so). Perhaps your host is doing the same.

1
  • It's the HTML 5 version being used here. I'm using Chrome with Flash disabled. But I checked on another browser with Flash enabled too with the same issue.
    – Doyley
    Nov 22, 2016 at 14:58
0

OK I solved it. Turns out somebody had tried to install the No Flash Image Uploader extension at some point and then deleted it, but not correctly. I removed all traces and it's working again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.