1

In my Magento website it does not show the currency symbol next to the price, but this only happens when I click on a product to see the details of it. Otherwise it shows.

Magento ver 1.9

link to the product

6
  • you want to disable the currency letter? like AFN2,900.00 to 2,900.00
    – Crock
    Commented Nov 21, 2016 at 10:23
  • @Crock I would like to display it like AFN2,900.00 as it is showing currently 2900. Commented Nov 21, 2016 at 10:32
  • Please click on the product to see how is it showing the price. Commented Nov 21, 2016 at 10:33
  • There is cache and reindex problem . i have checked. if we click the size of the product. like price shown with currency. only problem on first time page load. please clear the cache and clear reindex.
    – Crock
    Commented Nov 21, 2016 at 10:55
  • @Crock but for simple products when there is no attribute to select it always shows the price without the currency symbol. Commented Nov 21, 2016 at 11:51

2 Answers 2

0

Sorry i cant comment as i have not enough reputation yet.

/app/design/frontend/DESIGN_PACKAGE/default/template/catalog/product/view.phtml

Can you verify that there is a call to <?php echo $this->getPriceHtml($_product) ?>? My guess is that your used template is fetching the price with another function and not including the price.html block.

0
  1. Check the Currency Settings: Make sure that the currency symbol is enabled in your Magento store's currency settings. To do this, go to System > Configuration > Currency Setup, and make sure the "Display Currency Symbol" option is set to "Yes".

  2. Check the Product Price Settings: Check that the price settings for individual products are set to display the currency symbol. To do this, go to the product edit page in the Magento admin panel and look for the "Price" field. Make sure the "Display Actual Price" option is set to "Yes" and the "Display Actual Price With Currency" option is also set to "Yes".

  3. Check the Theme Files: It's possible that the issue is related to the theme files used in your website. Check the template files for the product detail page (typically located in the app/design/frontend/[your_theme]/template/catalog/product/view.phtml file) and ensure that the price display code includes the currency symbol code. You can compare it with the template file used on the category pages where currency symbol is displaying.

  4. Clear Cache: Sometimes, caching can cause issues with the display of currency symbols. Try clearing your Magento cache to see if that resolves the issue. You can do this by going to System > Cache Management and selecting "Flush Magento Cache".

  5. Check with Extensions: If you have any extensions installed in your Magento store related to currency or pricing, check their settings to ensure that the currency symbol is enabled and set to display properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.