0

I am working with Magento 1.9.2 and send email to a friend is not sending emails. It gives sent successfully report message. But not sending. Any clue how to debug?

0

Try this,

Got to System Transaction mail and load Send Product to Friend and check it loaded or not

enter image description here

then go to System -> Configuration -> Catalog -> Email to a Friend and check below configuration is fine or not

enter image description here

then check if not working share me your error.log

| improve this answer | |
  • in the log i found : 'Zend_Mail_Protocol_Exception' with message '5.7.1 <ideachanges@gmail.com>: Sender address rejected: not owned by user bineesh@sysbrick.com | the registered mail on system is bineesh@sysbrick.com . But the user may input any email , right ? so how to solve it. ? – Bineesh Nov 19 '16 at 8:57
  • Transaction mail is loading – Magento 2 Nov 19 '16 at 9:00
  • contacts are going. – Bineesh Nov 19 '16 at 9:40
  • but i can send using bineesh@sysbrick.com – Bineesh Nov 19 '16 at 9:43
  • What is the problem give me your site url – Magento 2 Nov 19 '16 at 9:51
0

Check you've got postfix installed and make sure you've configured it. Otherwise check IPTables to ensure you've not got an outbound drop rule that's not allowing if out.

Check IPTables with iptables -L if that has no rules then please share with me your post fix configuration.

Also check the service via service postfix status

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.