1

I am getting this error on my local magento.

Fatal error: Class 'Mage_Xmlconnect_Helper_Data' not found in /var/www/magento/app/Mage.php on line 546.

Edit:

I have checked the file is there on the correct path. Also I have checked the file was not in include/src directory so copied the directory to this path also and compiled from command line,but getting the same error, Any idea how to fix it??

closed as off-topic by Fabian Blechschmidt, Amit Bera, Marius, Dexter, Mufaddal Oct 6 '14 at 4:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Fabian Blechschmidt, Amit Bera, Marius, Dexter, Mufaddal
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you disabled the cache? If yes, set <disable_local_modules> to true in app/etc/local.xml. Then check again. If the error is not appearing, then it means one of your custom module contains the issue. You can start from that point – Sukeshini Feb 7 '14 at 6:19
  • It was enabled, but as I am unable to go to admin because of this error, unable to check it. – Tariq Aziz Feb 7 '14 at 6:24
  • I have updated the local.xml. Now I have to clear cache but I am unable to go to the cache management page in admin panel. Also the cache directory is empty and getting the error. – Tariq Aziz Feb 7 '14 at 6:27
  • 1
    Do you have "compilation mode" enabled? – oleksii.svarychevskyi Feb 7 '14 at 11:53
  • 1
    As @oleksii.svarychevskyi asked - if you have files in src then you are looking at an issue related to compiler. – benmarks Feb 7 '14 at 12:50

Browse other questions tagged or ask your own question.