6

I'm using Magento 2 CE with Porto Theme.

Also referred but it's for Magento 1

How to remove paypal express checkout link from mini cart in right column

I have tried from Admin Paypal Settings. But logo is still displaying on

How to remove it from Mini Cart & Shopping Cart Page?

4

Copy this file to your custom theme:

vendor/magento/module-checkout/view/frontend/web/template/minicart/content.html

to

app/design/frontend/PACKAGE/THEME/Magento_Checkout/web/template/minicart/content.html

And remove the line number 59:

<div data-bind="html: getCartParam('extra_actions')"></div>

Or copy the file that renders the specific PayPal logo here:

vendor/magento/module-paypal/view/frontend/templates/express/shortcut.phtml
3

You can remove logo using backend.

Stores -> Configuration -> Sales -> Payment Method

Paypal Express Checkout Tab

Click Configure Button,

Go To Basic Settings - Paypal Express Checkout section,
Click on Advanced settings.

Set No to Display On shopping Cart option.

  • I already tried on Magento 2 CE. It's not working at all. – Ankit Shah Nov 17 '16 at 7:16
  • Have you remove cache and var folder? Are you using Paypal Express Checkout? – Rakesh Jesadiya Nov 17 '16 at 7:16
  • Yes tried all. I think need to override with xml file. Last option – Ankit Shah Nov 17 '16 at 7:18
  • have you found any solutions for this issue, If yes Please share your solutions. – Rakesh Jesadiya Nov 17 '16 at 11:58
  • Nope. I didn't get my solutions. Answer which u have given i already tried before Posting the Question – Ankit Shah Nov 18 '16 at 1:14
3

There's a bug in Magento 2.1 where "Display On shopping Cart" option doesn't work.

More information: https://github.com/magento/magento2/issues/6073

1
  • Login in admin panel
  • Stores -> Configuration -> Sales -> Payment Method
  • Select Payments Standard tab -> Basic Settings - PayPal Website Payments Standard
  • Advanced Settings -> Display on Shopping Cart => No

enter image description here

0

Thanks Erfan for finding the Magento bug link.

Magento has indeed fixed this issue but it has only been applied to their 2.2 code base. If you are on a previous version you can replicate their commit changes, https://github.com/magento/magento2/commit/b4b721444be8c6257d64059b3b0b5d0f1fb1466b into your site.

In a custom module overwrite the PayPal Minicart Button Block

app/code/YourCompany/YourModule/etc/di.xml

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:ObjectManager/etc/config.xsd">
    <preference for="Magento\Paypal\Block\Express\InContext\Minicart\Button" type="YourCompany\YourModule\Block\Express\InContext\Minicart\Button" />
</config>

app/code/YourCompany/YourModule/Block/Express/InContext/Minicart/Button.php

<?php
namespace EsteSolutions\AddToCart\Block\Express\InContext\Minicart;

class Button extends \Magento\Paypal\Block\Express\InContext\Minicart\Button
{
 /**
 * Check `visible_on_cart` config value
 *
 * @return bool
 */
private function isVisibleOnCart()
{
    return (bool)(int) $this->config->getValue('visible_on_cart');
}   

/**
 * @return bool
 */
protected function shouldRender()
{
    return $this->payment->isAvailable($this->session->getQuote())
        && $this->isMiniCart
        && $this->isInContext()
        && $this->isVisibleOnCart();
}
}
?>
  • $this->config and $this->payment are private variables... – Pol Ravalitera Nov 6 '17 at 9:55
0

Create event.xml in your custom module like this and disable "paypal_shortcuts" observer

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Event/etc/events.xsd">
    <event name="shortcut_buttons_container">
        <observer name="paypal_shortcuts" instance="Magento\Paypal\Observer\AddPaypalShortcutsObserver" disabled="true"/>
    </event>
</config>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.