3

I am using 1.9.1.0. When I Click Continue Button on Shipping Method. The Page Redirect to cart Page. After I analysis the error on js. I have tried disable and enabling the various shipping methods no joy having same issue.

please help me out from the issue. I have posted the error below. its taken by browser console.

POST https://example.com/checkout/onepage/saveShippingMethod/ 500 Internal Server Error 403ms   c359267...57db.js (line 1530)


"NetworkError: 500 Internal Server Error - https://example.com/checkout/onepage/saveShippingMethod/"


The error 1530 line below:-

this.transport.send(this.body);


The Below Steps are already done:-
1. Changing the file permissions
2. Increasing memory_limit

Error on system.log:-

2016-11-17T09:21:22+00:00 ERR (3): Strict Notice: Declaration of Sm_Market_Block_Page_Html_Head::addItem() should be compatible with Extendware_EWCore_Block_Override_Mage_Page_Html_Head::addItem($type, $name = NULL, $params = NULL, $if = NULL, $cond = NULL) in /usr/share/nginx/html/includes/src/Sm_Market_Block_Page_Html_Head.php on line 94

and think Extendware_EWCore is not compatible so i was disabled the module. having no joy. same issue happening.

6
  • debug in Sm_Market module – Vaibhav Ahalpara Nov 17 '16 at 10:12
  • thinks, its not related to shipping method. – JohnS Nov 17 '16 at 10:15
  • @JohnS Have You Fixed the issue ? – Crock Nov 21 '16 at 3:48
  • @Crock No still having the issue – JohnS Nov 21 '16 at 3:50
  • May i know , Are you config in new server, and if yes. what are the changes makes in php.ini? – Crock Nov 21 '16 at 3:52
2

Go and Open again your php.ini config file. Please change the below values

  1. short_open_tag = on (remove ; symbol).
  2. Change max_execution_time = 30 to max_execution_time = 1800
  3. Change upload_max_filesize = 2M to upload_max_filesize = 32M
  4. Change post_max_size = 8M to post_max_size = 32M
2
  • yeah. now working. i dint know how it should be, thanks. – JohnS Nov 21 '16 at 4:12
  • 1
    How do these config changes remedy the issue? – Laith Feb 23 '18 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.