3

I've been stuck for hours on this one.

Product I'm working on: this site

I've made this configurable product, enabled swatches and added photos for each of those associated products. However when I click on color and size, can't get main image to change.

How do I fix it ?

  • have you set the individual images to the associated products? – Teja Bhagavan Kollepara Nov 15 '16 at 10:21
  • yes I have set those. you can see that I have set them if you add grey sweatshirt to basket and click view basket, grey sweatshirt photo shows up – Marijus Nov 15 '16 at 10:32
  • did you give sreen shot of associate product ? that you set image for that product. set image for all small , thumbnail and large image – Jigs Parmar Nov 17 '16 at 10:59
  • You fill label images from configurable product with value of attribute swatch, you need to have all images in configurable products and separate for simple products – St3phan Nov 20 '16 at 12:34
  • I ran into an issue when trying to import the config swatches into a customer theme. I show the process i used to debug my problem in this post: magento.stackexchange.com/questions/132939/…, it might work for you to track down your issue following my steps. – circlesix Nov 22 '16 at 23:50
1

Many times theme not configured with RWD color swatch , if the theme is not design by taking base of RWD theme then it may possible that your swatch want wont work,

or may be if you have installed some gallery extension then also main image wont change.

You can try below solution for this problem

1) rename your default media.phtml and put rwd theme media.phtml and check.

2) you miss this js/lib/elevatezoom/jquery.elevateZoom-3.0.8.min.js file in your header for product page , please add this line in your local.xml file

<catalog_product_view>

    <reference name="head">

        <action method="addItem"><type>skin_js</type><script>js/lib/elevatezoom/jquery.elevateZoom-3.0.8.min.js</script></action>

    </reference>

    <reference name="product.info.media">

        <block type="core/text_list" name="product.info.media.after" as="after" />

    </reference>

</catalog_product_view>

in your head section of product page.

3) also add below code in your local.xml

<default>

    <reference name="head">

            <action method="addJs"><script>lib/jquery/jquery-1.10.2.min.js</script></action>
            <action method="addJs"><script>lib/jquery/noconflict.js</script></action>

            <action method="addItem"><type>skin_js</type><name>js/lib/modernizr.custom.min.js</name></action>
            <action method="addItem"><type>skin_js</type><name>js/lib/selectivizr.js</name></action>
            <action method="addItem"><type>skin_js</type><name>js/lib/matchMedia.js</name></action>
            <action method="addItem"><type>skin_js</type><name>js/lib/matchMedia.addListener.js</name></action>
            <action method="addItem"><type>skin_js</type><name>js/lib/enquire.js</name></action>
            <action method="addItem"><type>skin_js</type><name>js/app.js</name></action>
            <action method="addItem"><type>skin_js</type><name>js/lib/jquery.cycle2.min.js</name></action>
            <action method="addItem"><type>skin_js</type><name>js/lib/jquery.cycle2.swipe.min.js</name></action>
            <action method="addItem"><type>skin_js</type><name>js/slideshow.js</name></action>
            <action method="addItem"><type>skin_js</type><name>js/lib/imagesloaded.js</name></action>
    <action method="addItem"><type>skin_js</type><name>js/minicart.js</name></action>

    </reference>

</default>

If files were missing then copy those files from RWD theme to your theme

  • I've bought theme which supports color swatches. Here's example shopper.queldorei.com/women/configurable-product.html of a product from that theme. Should I take actions you've written ? – Marijus Nov 17 '16 at 14:27
  • @Marijus Have you apply new security patch 8788 ? – Murtuza Zabuawala Nov 17 '16 at 18:05
  • @Marijus you can try my way and check what is the problem – Murtuza Zabuawala Nov 17 '16 at 18:09
  • Tried these steps you've written however it did not help. Any idea how can I debug this problem ? – Marijus Nov 18 '16 at 17:44
  • 2
    I've added you on linked in. Can you please respond to me on linkedin ? – Marijus Nov 21 '16 at 13:24
1

Check this URL to configure magento default swatch properly : Change product image for configurable products

Note : If the theme is not designed based on RWD theme or if you have installed any module/extension for swatch then it may possible that your default magento swatch will not work.

  • The theme supports configurable swatches. I've set up everything like in that tutorial. – Marijus Nov 18 '16 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.