3

Magento has just released community edition 1.9.3.1.

What's the difference with 1.9.3.0? Only bugfixes from previous release or also other modifications?

Are there any backward-incompatible changes?

Is it also safe to upgrade directly from Magento 1.9.2.4?

2

According to the release notes, the only known issue as of today is:

You currently cannot upgrade to this version using Magento Connect Manager. We expect to resolve this issue soon.

Here's the list of changes directly from the release notes: http://devdocs.magento.com/guides/m1x/ce19-ee114/ce1.9_release-notes.html#ce19-1931

Bug fixes:

  • We restored the old tax calculation algorithm for shipping charges. The patch to apply new calculation will be available on request.
  • Resolved an issue with setting the session lifetime to 0.
  • The monthly cron job that cleans up the table that contains IP addresses and passwords runs properly.
  • All configurable product images are imported.
  • You no longer get an exception due to an undefined addCrumbs() method call.
  • Resolved the error Notice: Undefined index: session_expire_timestamp when accessing the storefront.
  • Values for drop-down label values are saved correctly.
  • The "Price as configured" for bundle products displays correctly in the shopping cart.
  • Auto-generated passwords are sent to new customers as expected.
  • The method Mage_Api_Model_Server_Handler_Abstract::processingMethodResult() accepts scalar and array values.
  • The default MySQL Full-Text search works as expected; it no longer returns all products.
  • Catalog price rules return the correct price. Indexers now update all products instead of skipping the last product updated.

Security improvements:

  • Prevented a potential Cross-Site Request Forgery (CSRF) vulnerability by changing the form key when a customer signs out of the storefront.
  • Prevented a potential Cross-Site Scripting (XSS) vulnerability when adding a category.

After checking it seems like there is only one security improvement in 1.9.3.1 that you can find here: https://gist.github.com/digitalpianism/9750b55c021832514a25c92695d735d9 . Please note that this fix is not included in any security patch as of today. #2 in the list above seems to be a wrong copy/paste as a similar line was already in 1.9.3.0 release notes

So there's no known backward incompatible changes between 1.9.3.0 and 1.9.3.1 BUT there is a backward incompatible change between 1.9.3 and 1.9.2.4 you can find details here: https://magento.stackexchange.com/a/142013/2380

And yeah it's totally safe to upgrade directly from 1.9.2.4

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.