1

my client bought a template from TemplateMonster and I followed their indiciazioni on installation and configuration of the php.ini, I have always an error when I use

php bin / magento setup: static-content: deploy

Compilation from source:
frontend / Magento / blank / en_US / TemplateMonster_Megamenu / fonts / font-awesome-4.5.0 / less / list.less
variable @ fa-css-prefix is ​​undefined in /home/omadadesign.com/var/view_preprocessed/css/frontend/Magento/blank/en_US/TemplateMonster_Megamenu/fonts/font-awesome-4.5.0/less/list.less file list.less on line 4, column 2
2 | // -------------------------
3 |
4 | . @ {Fa-css-prefix} {-ul
5 | padding-left: 0;
6 | margin-left: @ make-them-width;
> | list-style-type: none;

The TemplateMonster Service says it is a server configuration issue but I have tried to install a new version of Magento without their theme and everything works properly. According to you it depends on the theme? There are server configurations that need to be modified to avoid that mistake?

Thank you!

3

Just in case anyone needs this. The guys from Template Monster support told me to erase the "less" folder in these two places:

theme001\app\code\TemplateMonster\Megamenu\view\frontend\web\fonts\font-awesome-4.5.0\

theme001\app\code\TemplateMonster\NewsletterPopup\view\frontend\web\fonts\font-awesome-4.5.0\

After doing that, the issue was fixed.

0

try adding the some different version of font-awesome.

if issue still persist use CDN. first delete view_processed then try deploying again.

2
  • Hello, thanks for the answer. I try now to update the font-awesome file For now I do not use CDN because the site is on a development server
    – Ciakkino
    Nov 14 '16 at 7:47
  • I downloaded the 4.7.0 version and updated .less I found but I always this error. I tried to download the original folder of magento but I always make the same mistake. But if I use php bin / magento setup: static-content: deploy on standard magento I do not mistake and it all works on a regular basis. You have suggestions for this error?
    – Ciakkino
    Nov 14 '16 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.