Im trying to migrate from magento1 to magento2. Installed data migration tool. filled everything out correctly in my config file.

            <database host="mymagento1.com" name="magento1db" user="magento1user" 
            <database host="localhost" name="magentodb2" user="magento2user" 

my magento 1 install is on a remote server. I have enabled remote access to that database.

Problem I having is when I run

/magento migrate:settings --reset


I get this error

SQLSTATE[HY000] [1045] Access denied for user 'magento1user'@'s1.mydomain.com' (using password: YES)

SQLSTATE[HY000] [1045] Access denied for user 'magento1user'@'s1.mydoamin.com' (using password: YES)

Seems to be trying to use my magento1 user name to connect to my localhost server to make a connection. I did not specify my hostname for my localhost (destination server) and while running the migrate command it responds back with my hostname from destination and my username from source.

I also added in


I get the same results. Am I missing something?

2 Answers 2


Please change

  <database host="localhost" name="old magento database name" user="old database user 
    name" password="old db host password"/>
  <database host="localhost" name="new magento database name" user="oldnew database 
   name" password="new db host password"/>

And also add after that

 <crypt_key>Old magento version key from oldVersion_folder\app\etc\local.xml 

That`s it. After make these changes your code working. Best of luck.


Seem you did ask our team a few hours ago about our migration tool. We've sent you reply already.

Your question here relates to Magento default tool, so it's beyond scope we can answer. Just want to include here an answer to one of our users on Reddit who did ask us a question why our migration tool vs. Magento default tool. A plus point is that our visualized setting dashboard will simplify and ease your setting and migration process.

Anyway, hope you can figure it out the solution with default Magento core tool.

Regards, Ubertheme team

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.