1

After upgrading to Magento 1.9.3 from 1.9.2.4 the product image Uploade button is not working.

When I choose the image and clicks OK the browser just freezes and crashes. I tried again on Firefox, and gets the message that a script in js/lib/uploader/flow.min.js:2 is not responding.

I run PHP 5.6.27-1 on Ubuntu (So I cant install the html5 upload button from Magento Connect as this does not support over 5.6.25)

EDIT: It seems that the function can not get the max filesize (this.file.size / this.flowObj.opts.chunkSize) in this part of the function the chunkSize is 0 and I believe that is the reason for the crashing

  • Seems like the error is in e.prototype.bootstrap function? – Dennis W Nov 11 '16 at 10:18
  • Same problem here. Any solutions? – Seb Nov 15 '16 at 9:46
  • @Seb I have found the problem. My max post size was set to "0" (unlimited) but this resulted in a "Divided by zero" error. I changed the limit to a number and restartet PHP. – Dennis W Nov 15 '16 at 11:04
3

I have not found the real problem, but a workaround. De-Minifiy the file /js/lib/uploader/flow.min.js.

Then find the rows

bootstrap: function() {
    this.abort(!0), this.error = !1, this._prevProgress = 0;

And directly after this add the following line

this.flowObj.opts.chunkSize = 1048576;

For some reason, the chunkSize is 0 and in the following row the file size is divided by the chunk size. So if chunk size is 0, then this will fail.

Hope that helps.

  • Hi there. Thanks your your answer. You are totally right. I found last night that my post_max_size was set to 0 (Should be unlimited according to the docs). I think the developers should fix this. I Did not try your workaround but looking at it I am sure it would work for those who must have the unlimited post_max_size. Thanks! – Dennis W Nov 15 '16 at 11:07
2

I added the line this.flowObj.opts.chunkSize = 1048576; to flow.min.js.
But now I get this error:
enter image description here

I'm using HHVM on Nginx

Edit: fixed it OPEN: /etc/hhvm/php.ini ADD: hhvm.enable_zend_ini_compat=false


  • @Julius , Try to edit your php.ini and set upload and post's max sizes above the 1048576. Or just set it to like 1G – Dennis W Nov 28 '16 at 10:36
  • setting hhvm.enable_zend_ini_compat=false worked for me , i had trouble uploading larger files which is also resolved thank a ton – Bharath Jun 3 '17 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.