2

I've recently move my Magento shop from one server to another, and since then I haven't had else but problems. I can't blame the host because they are running on professional servers with CentOS, where I used to run it from a Mac Mini with MAMP Pro installed.

But the system doesn't send out mails, so I figured I would try to install the ASchroder SMTP Pro plugin for sending out mails through SMTP instead. But I can't install it from the Magento Connect Manager.

When I paste the install-path to the downloader, and press 'Install' it's only output is:

Connection Error try again later.

I've looked at my settings, file permissions and such, but nothing has worked so far. My Magento Connect Manager settings is as following:

My settings for Magento Connect Manager

As you can see, I can't select Local Filesystem.

Can anybody help me with either the mail sending problems or the Connect Manager installation problems?

  • Making Downloader folder writable to 777 will work – Shruti Feb 6 '14 at 9:45
1

Please make sure that you're entering the correct FTP details by trying to access the server using an FTP client like FileZilla/SmartFTP etc.

If you are, make sure that you are using the correct key from MagentoConnect:

http://connect20.magentocommerce.com/community/ASchroder_SMTPPro

Alternately, as a temporary solution, you can download the source files directly off of MagentoConnect using this tool:

http://freegento.com/ddl-magento-extension.php

Simply paste the key into the textarea, then install onto your file server via FTP client.

  • 1) FTP details are correct 2) Downloading and uploading the file generates this error: Error moving uploaded file – Thomas Urup Schjerlund Feb 6 '14 at 9:17
  • Check your folder permissions on the server, seems to be the problem. Right click on the folders and make sure that you have the correct permissions (i.e read/write), you may want to contact your host – Moose Feb 6 '14 at 9:23
1

The Local Filesystem option is disabled if the method Maged_Controller::isWritable returns false.
See Maged_Controller::settingsAction():

$fs_disabled =! $this->isWritable();

Make your downloader folder writable and it should work.

If the problem persists see what the isWritable method looks like and what conditions have to be met.

[EDIT]
As for the error mentioned in the comments

Warning: include(DOMDocument.php): failed to open stream: No such file or directory in ...

you need to install the php-xml module

  • Making the downloader-folder writeable, makes the Local Filesystem selectable again, but when I change the settings and save them, they changes doesn't get saved. – Thomas Urup Schjerlund Feb 6 '14 at 9:22
  • @ThomasUrupMichaelsen. Anything in var/log ? – Marius Feb 6 '14 at 9:24
  • 2014-02-06T09:25:49+00:00 ERR (3): Warning: include(DOMDocument.php): failed to open stream: No such file or directory in /home/web001/www/lib/Varien/Autoload.php on line 93 2014-02-06T09:25:49+00:00 ERR (3): Warning: include(): Failed opening 'DOMDocument.php' for inclusion (include_path='/home/web001/www/downloader/lib:/home/web001/www/app/code/local:/home/web001/www/app/code/community:/home/web001/www/app/code/core:/home/web001/www/lib:.:/usr/share/pear:/usr/share/php') in /home/web001/www/lib/Varien/Autoload.php on line 93 – Thomas Urup Schjerlund Feb 6 '14 at 9:30
  • @ThomasUrupMichaelsen. See my update. – Marius Feb 6 '14 at 9:34
  • Already done - but doesn't change much for me. – Thomas Urup Schjerlund Feb 6 '14 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.