0

With the recent security updates, I've been unable to apply patch 3941 onto Magento 1.9.1.0.

I did initially install the 8788 V1 patch, but I reverted that patch to install 8788 V2. I've checked and never installed 1533 patch. When I try to apply SUPEE-3941 I get the following:

sh PATCH_SUPEE-3941_EE_1.14.0.1_v1-2015-02-10-08-32-02.sh

SUPEE-3941 to magento 1.9.1.0 error

I checked my applied patches log and confirmed patch 1533 has never been applied. Seems to be a different error than what everyone else was referencing. I tried making a blank downloader folder, but I ended up getting a different error related to the files not existing.

Any ideas?

UPDATE: Looks like i didn't remove 8788-V1 Yet. I removed it and 1533. When trying to apply 3941 I get the same error as above.

but when I try to apply 8788-V2, I get a different error almost like it can patch but needs something. Probably showing up since I don't have 3941 installed yet. Attempting to install 8788-V2 after reverting patches. 3941 not applied

  • You need to apply patch in correct order. Some files in new patch may depends on version of last patch. For example, customer Account controller has been revised many times – leo Nov 10 '16 at 4:46
  • I just corrected part of my build. I confirmed I reverted 8788-V1 and 1533. But now when trying to apply 3941, I get the same error. I also just added another picture for when I try to apply 8788-V2. – Dequan W Nov 10 '16 at 7:46
0

Try below order to apply patch SUPEE-8788 v2

  1. Revert SUPEE-8788 v1/
  2. Revert SUPEE-1533 (if installed)
  3. Install SUPEE-3941 (if not installed yet)
  4. Install SUPEE-8788 v2

This order is suggested by Magento team itself here. Hopefully it should work.

  • So I just reverted 8788-V1 and 1533. But i'm still getting the same error I listed. I also just posted a picture for the error I get when trying to apply 8788-V2 – Dequan W Nov 10 '16 at 8:13
0

Looks like I figured it out. I reverted 1533, but then reapplied 1533 with 8788 V2 and it applied fine. Not sure how since 8788V2 was quoted to have 1533 included.

Looks like I don't need SUPEE-3941 since the things it's already included in 1.9.1.0 and onwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.