0

I have followed all the tutorials on github, did everything exactly as explained: 1. installed Redis 2. modmanned Cm_Cache_Backend_Redis 3. Tried with and without template.php in app\code\local\Mage\Core\Block 4. Obviously edited our local.xml and it has server specs:

    <host>127.0.0.1</host> <!-- or absolute path to unix socket -->
    <port>6379</port>

One thing remains no matter what we tried, we did verify with our host. Google gives only 4 unrelated results, so please... ;-)

We keep getting an error report containing this: a:4:{i:0;s:29:"Redis 'server' not specified.";i:1;s:1585:"#0 /magento/domains/domain.com/public_html/.modman/Cm_Cache_Backend_Redis/Cm/Cache/Backend/Redis.php(122): Zend_Cache::throwException('Redis 'server' ...')

I'm lost. Who has an idea what to try next?

Edit: Magento version 1.9.2 Did a PING on the server to redit and that came back with PONG as well.

0

FINALLY figured it out although it was pretty obvious.

My lines, which I copied from the many many sample sites, are

<host>127.0.0.1</host>

If you look at it, it is self explanatory, since it says it is missing a SERVER, so I looked at the (yup, should have immediately) local.xml.additional from Magento and noticed it should say server, and not host, like this:

<server>127.0.0.1</server>

Thanks for looking, hope it helps some others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.