1

After apply SUPEE 8788 patch error appears when you log in to the admin:

Fatal error: Class 'Unserialize_Reader_Null' not found in /var/www/html/lib/Unserialize/Reader/Arr.php on line 105

Magento 1.7.0.2 installed SUPEE 8788v2

This solution won't work: SOLVED: new Unserialize_Parser class throws exceptions on NULL values

1

It's definitely a problem with the patch.

SUPEE-8788 v2 provides a new file lib/Unserialize/Reader/Null.php.

Please double check that this file is present on your Magento install.

If it's not present, that means v2 was not properly installed, thus you need to patch v2 correctly.

If it's present, you probably have some sort of compiler that had not been recompiled after patching (example, Magento compilation under System > Tools > Compilation)

  • 1
    Patch is installed correctly (includes Null.php). I do not use Magento Compiler. – MalT Nov 7 '16 at 10:08
  • @MalT interesting. How does the file look like ? Does it look okay ? – Raphael at Digital Pianism Nov 7 '16 at 10:11
0

Problem solved. It was enough to give the appropriate user and group.

Example:

sudo chown -R username:group

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.