0

I'm trying to edit (or redirect) some category menus to other categories. Example, I have two sub-categories called "Compression Wear" (id 60 - /compression-wear.html) AND "Compression Wear" (id 67 - /compression-wear-secondary.html). Each are under different parent categories, same store. I'd like to only add products to id 60 and have them appear in id 67 also. I figured the best route was to redirect id 60 to id 67 using URL Rewrite Management.

Problem:

After clicking to edit a URL Rewrite, I'm unable to click to edit any field except for "Request Path". I made a custom URL Rewrite but that did not redirect. I was able to click and edit the fields when I made my own Custom Rewrite, however, when and if I try to edit it after saving, same problem, I'm unable to click and edit fields. Screenshot and Code below.

Unable to click to edit fields of URL Rewrite and related code from Inspect

The code on the right for one of the paths I was trying to click and edit says, title="Target Path" disabled="disabled" if I change that to disabled="enabled" nothing happens, but if I remove it completely, I'm able to cursor over the text field and edit things. This of course is just in Chrome Inspector, so no real changes are being saved.

What I've Tried:

I've tried reindexing, recaching, restarting apache, logging in Firefox, Chrome, IE - all to no resolution. I do believe at one point I was able to redirect just fine without this issue. I'm unaware if this is caused by an extension/module installed in Magento (or to go about finding if it is).

Please help

Is it possibly something to change on my server end, as I've been unable to find anything related to my problem, except for one "not really answered or followed-up" post. Post found here.

0

Update from Original Poster:

This was a dumb mistake on my part and I've resolved the issue. If the "Type" of rewrite is "System" it cannot be edited as this generated by Magento. I simply searched for the id of the category I wanted to redirect. In my case, id 67, and deleted the "System" rewrite. Then, I created a custom URL rewrite and like normally, I created the rewrite.

It may be due to my own error (lack of sleep/focus, and many tabs open) that I was trying to edit the "System" rewrite instead of the "Custom" one - which caused me to think the "Custom" rewrite was not editable as well.

Hope this helps anyone, if they make my same dumb mistake.

Moral of the story: "System" type rewrites are not editable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.