2

I just installed Magento 2.1.2 and after login into the admin I immediately got this error:

There has been an error processing your request
Exception printing is disabled by default for security reasons.
Error log record number: 202497054639

I read on many forums how to solve it but I think most of them are for Magento 1 and not 2.

How can I solve this and what information do I need to post here?

1
  • You should look in the folder var/report/ for a file which name is that error log record number, so var/report/202497054639. Please update your question and add it's content. – 7ochem Nov 2 '16 at 14:36
6

try this via command line

php bin/magento deploy:mode:set developer

Possible duplicate https://stackoverflow.com/questions/34629697/how-to-turn-on-error-messages-in-magento-2/34740378#34740378

1

Run following commands in given order:

 php -dmemory_limit=6G bin/magento maintenance:enable
 rm -rf var/cache/* var/page_cache/* var/generation/* var/di pub/static/* var/view_preprocessed/*
 php -dmemory_limit=6G bin/magento deploy:mode:set production -s
 php -dmemory_limit=6G bin/magento setup:upgrade
 php -dmemory_limit=6G bin/magento setup:di:compile
 php -dmemory_limit=6G bin/magento setup:static-content:deploy
 php -dmemory_limit=6G bin/magento cache:flush
 php -dmemory_limit=6G bin/magento maintenance:disable
0

I just wasted a day turning in circles with these admin login issues - either report error like yours, or weird certificate complaints.

As mentioned, look in the report file (it is in var/reports)

I have had 2 kinds of errors

1) errors about files or streams that cannot be found or opened: make sure you clear caches, pagecaches & reindex

2) error about open_basedir restriction in effect linked to /etc/pki/tls/certs

/home/alpinewi/m2.alpinewines.co.uk/magento2/vendor/composer/composer/src/Composer/Util/RemoteFilesystem.php(801): Composer\Util\RemoteFilesystem->getSystemCaRootBundlePath()

I eventually went digging on the bug tracker of Magento 2 and found something! This is all caused by composer and the version of composer that 2.1.2 is tracking along, which is an alpha

Edit you composer.json file

find the line

"composer/composer": "@alpha"

change to

"composer/composer": "1.1.2 as 1.0.0-beta1"

now run

composer update

and you should see

Updating dependencies (including require-dev)
- Installing composer/ca-bundle (1.0.6)
Downloading: 100%
- Removing composer/composer (1.0.0-beta1)
- Installing composer/composer (1.1.2)
Downloading: 100%

The ca-bundle is what fixes the error, I think. it was totally missing in the more recent alpha version

see https://github.com/magento/magento2/issues/4359

1
  • I have just had the same problem on a bitnami instance which I updated to 2.1.2 and this fix worked again – iphigenie Nov 8 '16 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy