2

I've got category URLs like .*/.html in Magento2. Ideally I prefer .*.html, however I'll settle for .*/.

So I go to the Magento admin and change the preference Stores -> Configuration -> Catalog -> Search Engine Optimization -> Category URL Suffix to the empty string

enter image description here

However with caching disabled and a reindex, the category pages are return HTTP 404(page not found). I've even tried deleting all products and categories, then reloading with the revised setting, but still getting 404(page not found).

Any idea what might be wrong?

0

Try bellow my suggestions for you.

run below commands

php bin/magento indexer:reindex

php bin/magento cache:clean

Delete var folder

Delete your browser cache.

I hope it will work for you.

  • Thanks for this. This is how I know I'm not crazy, because I've done these things and the problems persist. I have some ideas how to troubleshoot, was just hoping there may be something little I've missed. – quickshiftin Nov 4 '16 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.