1

I am facing the catalog product flat reindexing issue in my project. I have tried many solution, but can't get any success. I have tried following solutions around Google:

1- I truncated all the catelog_producr_flat tables(like catalog_product_flat_1, catalog_product_flat_2, catalog_product_flat_3), and then clear all the cache and then reindexing. but not get any success

2- I changed the var/locks folder permission to 777 and empty that folder,then clear all the cache. Then try to reindex, but not success.

3- I tried manually reindex via following code given below and then clear all the cache , but not get any success:

<?php 
 require_once 'app/Mage.php'; 
 $app = Mage::app('admin'); 
 umask(0); 
 for ($index = 1; $index <= 8; $index++) { 
     $process = Mage::getModel('index/process')->load($index); 
     $process->reindexAll(); 
 }
 ?>

4- Increase your execution time value in the .htaccess file and then clear all the cache, as below

php_value memory_limit 128M

php_value max_execution_time 18000

i have tried all the process but can't get any success, pleas help me.

  • Did you by any chance figure out the problem, seems like I having the same exact issue? – crashtestxxx May 29 '17 at 12:17
0

Unfortunately no any proper solution. But i found a 3rd party extension "Aitoc" in my project, after disabling it, my problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.