2

When I run php bin/magento setup:static-content:deploy those are the errors that will occur. by the way I just upgraded my magento version 2.0.7 to magento 2.1.1 and it gives error.

enter image description here

8
  • Go to the file and remove the ._lib-popup-button-close-icon class and deploy again. Nov 3, 2016 at 2:48
  • Sorry but the problem still persists. It occurs again even if, I followed your instructions Nov 3, 2016 at 2:52
  • We are facing same issue, please go to original theme file and remove. var files processed from original theme file. Nov 3, 2016 at 2:54
  • Yes and it really bothers me. I've been searching from google for around 2 days and still no luck Nov 3, 2016 at 2:55
  • What do you mean by removing the var files processed from original theme file? Nov 3, 2016 at 2:56

1 Answer 1

2

We are facing same issue, please go to original theme file and remove ._lib-popup-button-close-icon class and run setup:upgrade, deploy the static content again.

Remove below code from app/design/frontend/Smartwave/porto/web/css/source/_popups.less

._lib-popup-button-close-icon(
@popup-button-close__icon,
@popup-icon-font__content,
@popup-icon-font,
@popup-icon-font__size,
@popup-icon-font__line-height,
@popup-icon-font__color,
@popup-icon-font__color-hover,
@popup-icon-font__color-active,
@popup-icon-font__margin,
@popup-icon-font__vertical-align,
@popup-icon-font__position,
@popup-icon-font__text-hide
);

This issues might cause for the reason.

If you fells any styles issue, you have to write styles for that. Hope it helps.

1
  • Hello I just did that I removed that class you instructed me but still the same the error is still there. Nov 3, 2016 at 3:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.