2

I'm having a major issue that I cannot figure out after googling for hours. I have magento 2 installed on my local MAMP server. I've run through the installation process and can access the frontend with no problem, but the admin is giving me the ERR_TOO_MANY_REDIRECTS error and won't load. I installed magento 2 with http://127.0.0.1:8888 as the domain instead of localhost as I've seen that has caused some issues with others. The full path is http://127.0.0.1:8888/magento2. I've cleared cookies/cache, edited .htaccess files but nothing is working. Can anyone please assist me? I'd greatly appreciate it!

0

I found the solution.

In my case, I was importing an already existing Magento 2 database. The reason I was getting the error was because of the cookie domain in the database. Go to your database and look in the table core_config_data. You should see a path called web/cookie/cookie_domain. Make sure the domain matches the one you installed Magento 2 on. Ex: If you installed Magento 2 on local.dev/<magento-root> the entry in web/cookie/cookie_domain should be local.dev.

0

Issue: ERR_TOO_MANY_REDIRECTS - redirected you too many times

This issue is related cookie domain name.

For ex: if you already installed Magento 2 in www.example.com, and now you change magento base path to sub domain path like www.subdomain.example.com means, then you need to update your cookie domain entry inside of core_config_data table. You cannot access magento 2 backend so you can use following query to check record exist else use insert query.

SELECT * FROM  `core_config_data` WHERE  `path` REGEXP  'cookie_domain'

if record exit then update subdomain.example.com to the value column.

else

INSERT INTO `core_config_data` (`scope`, `scope_id`, `path`, `value`) VALUES ('default', 0, 'web/cookie/cookie_domain', 'subdomain.example.com');

Then flush cache using command php bin/magento cache:flush

Refresh magento 2 admin, now you can access admin. try this. thanks.

Note: if you are not using cookie domain, then don't configure this settings, if you configuration wrong then also you can face this error, so to fix that error update value to default configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.