0

I installed Magento 1.9.0.1 and right after the Installation I've got the following error (it resultet in a 504 Gateway Timeout).

I've modified the index.php to get the real error, since no log has been written.

Error in file: "/kunden/123123123/webseiten/mage-test/app/code/core/Mage/Weee/sql/weee_setup/install-1.6.0.0.php" - SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'intern_weee_tax' already exists, query was: CREATE TABLE `intern_weee_tax` (
  `value_id` int NOT NULL auto_increment COMMENT 'Value Id' ,
  `website_id` smallint UNSIGNED NOT NULL default '0' COMMENT 'Website Id' ,
  `entity_id` int UNSIGNED NOT NULL default '0' COMMENT 'Entity Id' ,
  `country` varchar(2) NULL COMMENT 'Country' ,
  `value` decimal(12,4) NOT NULL default '0.0000' COMMENT 'Value' ,
  `state` varchar(255) NOT NULL default '*' COMMENT 'State' ,
  `attribute_id` smallint UNSIGNED NOT NULL COMMENT 'Attribute Id' ,
  `entity_type_id` smallint UNSIGNED NOT NULL COMMENT 'Entity Type Id' ,
  PRIMARY KEY (`value_id`),
  INDEX `IDX_INTERN_WEEE_TAX_WEBSITE_ID` (`website_id`),
  INDEX `IDX_INTERN_WEEE_TAX_ENTITY_ID` (`entity_id`),
  INDEX `IDX_INTERN_WEEE_TAX_COUNTRY` (`country`),
  INDEX `IDX_INTERN_WEEE_TAX_ATTRIBUTE_ID` (`attribute_id`),
  CONSTRAINT `FK_INTERN_WEEE_TAX_COUNTRY_INTERN_DIRECTORY_COUNTRY_COUNTRY_ID` FOREIGN KEY (`country`) REFERENCES `intern_directory_country` (`country_id`) ON DELETE CASCADE ON UPDATE CASCADE,
  CONSTRAINT `FK_INTERN_WEEE_TAX_ENTT_ID_INTERN_CAT_PRD_ENTT_ENTT_ID` FOREIGN KEY (`entity_id`) REFERENCES `intern_catalog_product_entity` (`entity_id`) ON DELETE CASCADE ON UPDATE CASCADE,
  CONSTRAINT `FK_INTERN_WEEE_TAX_WEBSITE_ID_INTERN_CORE_WEBSITE_WEBSITE_ID` FOREIGN KEY (`website_id`) REFERENCES `intern_core_website` (`website_id`) ON DELETE CASCADE ON UPDATE CASCADE,
  CONSTRAINT `FK_INTERN_WEEE_TAX_ATTR_ID_INTERN_EAV_ATTR_ATTR_ID` FOREIGN KEY (`attribute_id`) REFERENCES `intern_eav_attribute` (`attribute_id`) ON DELETE CASCADE ON UPDATE CASCADE
) COMMENT='Weee Tax' ENGINE=INNODB charset=utf8 COLLATE=utf8_general_ci

#0 /kunden/123123123/webseiten/mage-test/app/code/core/Mage/Core/Model/Resource/Setup.php(644): Mage::exception('Mage_Core', 'Error in file: ...')
#1 /kunden/123123123/webseiten/mage-test/app/code/core/Mage/Core/Model/Resource/Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '1.6.0.0')
#2 /kunden/123123123/webseiten/mage-test/app/code/core/Mage/Core/Model/Resource/Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb('1.6.0.0')
#3 /kunden/123123123/webseiten/mage-test/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /kunden/123123123/webseiten/mage-test/app/code/core/Mage/Core/Model/App.php(428): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /kunden/123123123/webseiten/mage-test/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Model_App->_initModules()
#6 /kunden/123123123/webseiten/mage-test/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#7 /kunden/123123123/webseiten/mage-test/index.php(87): Mage::run('', 'store')
#8 {main}

How can I solve this problem?

  • i suggest install magento again – Vaibhav Ahalpara Oct 25 '16 at 8:59
  • Reinstalling issues this error again, so this is not a solution anyhow. :( Pretty bad that Mage has such errors in Mage2, too. – Max Oct 25 '16 at 9:12
  • drop database and then reinstall – Vaibhav Ahalpara Oct 25 '16 at 9:19
  • That doesn't change anything. Same error as before. – Max Oct 25 '16 at 9:45
0

open your database go to core_resource tabel and in this entry admin_setup change version and data version to 1.6.1.2 for both value hope this will help you

  • It just changes the error. Now its /webseiten/mage-test/app/code/core/Mage/Downloadable/sql/downloadable_setup/install-1.6.0.0.php that makes the problems here. – Max Oct 25 '16 at 9:15
  • hmm the sql that you install its old one or not match with your package , change all version and data version value in that table , for safer side take backup of that table – Murtuza Zabuawala Oct 25 '16 at 9:16
  • How can that be? I use the downloader.php from Magento itself. – Max Oct 25 '16 at 9:45
  • have you installed database from theme providor?? – Murtuza Zabuawala Oct 25 '16 at 9:50
  • if yes then then change value of all this version and data version in magento database – Murtuza Zabuawala Oct 25 '16 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.