1

I just upgraded my Magento v1.7 to v1.9 without too much complication. All the front end functionality seemed just fine but when I logged into the back end I noticed that two of the main pull down menus were not showing up... "Reports" and "System".

I was about to roll back to my backup until I found that one of my extensions that has it's own top level menu had an option that was a short cut to "SYSTEM -> SYSTEM" so I could view/change some of my system settings.

I don't seem to have any problems adding products, editing any CMS pages or any number of admin type functions. I did find that some items from the "System" menu I could handcraft a URL that would get me there. That tells me it's not an issue with not having the sufficient rights.

Double checked MySQL entries, just poking around and all look OK. I have 3 other admin level accounts and can log in but still no menus.

My issue seems familiar to another Stack Exchange issue from 5 months ago... System, Reports Menu not show in magento 1.9

While someone did offer up a solution the original poster never commented if it worked or not. I tried it and it didn't work for me.

My wild guess is that there is an XML file somewhere that controls what menus show up, what's listed under the menu and what conditions need to be met in order to display the menu. I've been under the hood a fair bit with Magento but real deep in tinkering with CORE config issues.

Any help is greatly appreciated!

Kevin E.

  • Maybe you have some cached css in browser, do you try to clear your cache with CTRL+R? Also you can try to unmerge css files under development tab. – electroid Oct 25 '16 at 4:17
  • Cache cleared, indexes rebuilt, both CSS and JavaScript are not merged. Went through Advanced->Advanced and disabled all 3rd party add ons... still no joy. – DeadboltSecurity Oct 25 '16 at 18:27
  • If you press F12 in your browser and refresh the page (F5) can you see any errors in console? – electroid Oct 26 '16 at 9:15
  • For me, F12 brings up my FireBug console. Disable that and it brings up the FireFox Dev tools but perhaps that's what you're asking. And no, there's no errors nothing unusual at all. I have debug on and can see that all the menus are referencing the Mage_adminhtml block and lot's of the menus controlled by various XML files but again, nothing unusual. – DeadboltSecurity Oct 26 '16 at 22:20
  • Did find one other 'issue'... I tried going to Magento Connect Manager and thought why don't I do REINSTALL of just the Mage_Core_Adminhtml module. No can do... with any module. I get this error in the console... CONNECT ERROR: Package community/Mage_Core_Adminhtml failed: Unknown SSL protocol error in connection to connect20.magentocommerce.com:443 – DeadboltSecurity Oct 26 '16 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.