2

TinyMCE has an very unfriendly feature for me: it escapes all accents to html entities once you switch from raw to visual and then to raw again.

I found the key that must be configured, now I would like to know the place to put the configuration for the backend editor to STOP escaping accents.

Anyone ? Thanks.

2
  • The problem with Magento 1.8.1.0 and Tiny Mce is that all changes to */js/mage/adminhtml/wysiwyg/tiny_mce/setup.js are not giving visible effect. Any hints where real config is placed or where to find those setup files that override standard setup.js in TinyMCE. THX
    – shopMAGES
    Feb 6, 2014 at 14:40
  • The comment of @EvgeniIvanov is correct, it worked fine here 1.8.0
    – Niloct
    Feb 6, 2014 at 20:00

3 Answers 3

2

in this file magento_installation_directory/js/mage/adminhtml/wysiwyg/tiny_mce/setup.js, on line 97(Magento 1.7.0.2 CE) you will find a variable named settings. You need to add this option: entity_encoding : "raw". You can read more about it here tinymce.com/wiki.php/Configuration:entity_encoding. Please note that if you upgrade Magento, you may need to apply this again.

1
  • Well, tough luck for us non English speakers. This does work, but it breaks if you enable "Merge JavaScript Files". Apparently the 'js/tiny_mce/tiny_mce.js' is loaded after the merged files. I'm working on a solution.Till then as a workarounf disabling JS merging globally and enable it on any Website you have. Oct 15, 2015 at 1:17
1

The configuraion file for TinyMCE is located here: *magento_installation_directory*/js/mage/adminhtml/wysiwyg/tiny_mce/setup.js

You can edit/add your settings to this file.

3
  • It would be stellar if you could update your answer to include context and example surrounding what's being asked vs merely posting a file-path.
    – davidalger
    Feb 1, 2014 at 0:30
  • 1
    in this file *magento_installation_directory*/js/mage/adminhtml/wysiwyg/tiny_mce/setup.js, on line 97(Magento 1.7.0.2 CE) you will find a variable named settings. You need to add this option: entity_encoding : "raw". You can read more about it here tinymce.com/wiki.php/Configuration:entity_encoding. Please note that if you upgrade Magento, you may need to apply this again. Best regards. Feb 1, 2014 at 13:10
  • Thanks @EvgeniIvanov, please add an answer with your solution so I can accept it.
    – Niloct
    Feb 6, 2014 at 19:58
0

Also try changing the encoding of file setup.js to utf8 using a text editor. I had problem with greek characters and i did this after adding entity_encoding : "raw"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.