4

At my clients webserver I'm trying to install Magento 2.1.2.

We have secured the domain with a Let's Encrypt SSL certificate and this seems to work fine.

Unfortunately I get two errors in the readycheck of Magento 2:

PHP Version Check Your PHP version is. The required PHP version is. Hide detail

Download and install PHP from www.php.net using this PHP Documentation.

For additional assistance, contact your hosting provider.

and

Cannot determine required PHP extensions: Warning: is_dir(): open_basedir restriction in effect. File(/etc/pki/tls/certs) is not within the allowed path(s): (/home/devcbs/:/tmp/:/var/tmp/:/usr/local/php56/lib/:/usr/local/php54/lib/:/usr/local/php55/lib/:/usr/local/php56/lib/:/usr/local/php70/lib/:/usr/local/lib/php/) in vendor/composer/composer/src/Composer/Util/RemoteFilesystem.php on line 914

PHP Extensions Check missing PHP extensions. Hide detail

The best way to resolve this is to install the correct missing extensions. The exact fix depends on our server, your host, and other system variables. Our PHP extension help can get you started.

For additional assistance, contact your hosting provider.

To get through the readycheck I edited composer.json and added "disable-tls":true. This fix will get me through the readycheck but does not solve the problem, because it causes more errors after the setup has been completed.

Edit: I've tried to readycheck Magento 2.1.2 setup on another webserver without any problems. On this server there're no cron jobs set so far.

Does anyone know what kind of problem with the webserver might be and better how to fix this?

I hope someone can help me out with this because I'm clueless.

  • it's probably a bit late but I had the same issue and was able to install and it looks to be running. No https unless you can edit that open_basedir parameter though – iphigenie Nov 4 '16 at 14:55
  • actually, I think https can be put back in, victory @twf-thimo – iphigenie Nov 4 '16 at 15:53
1

Your problem is that Magento 2 and up doesn't support PHP5.4 Which is what you're running indicated by your stack trace.

Install PHP5.7 or PHP7.0 and the required extensions and you should be good to go.

I understand it's a shared server but installing PHP7.0 will not affect the other clients on the server. You can have them running in parallel.

  • Alternatively if this is something you've already done then make sure your vhkst is running solely on php7.0 as you have a ref to php5.4 in your stacktrace – Timothy Frew Jan 1 '17 at 16:09
0

UPDATE: I'm fighting with this at the moment on a shared server.

I first thought maybe we do need to add the folder to open_basedir and configure ssl differently but no, after hours, that Didn't do it.

I eventually went digging on the bug tracker of Magento 2 and found something! This is all caused by composer and the version of composer that 2.1.2 is tracking along, which is an alpha

Edit you composer.json file

find the line

"composer/composer": "@alpha"

change to

"composer/composer": "1.1.2 as 1.0.0-beta1"

I also added a line in the main config to try to "skip" the tls step, but I don't think this is necessary

"disable-tls": true,

now run

composer update

and you should see

Updating dependencies (including require-dev)
- Installing composer/ca-bundle (1.0.6)
Downloading: 100%
- Removing composer/composer (1.0.0-beta1)
- Installing composer/composer (1.1.2)
Downloading: 100%

The ca-bundle is what fixes the error, I think

see https://github.com/magento/magento2/issues/4359

-1

This error indicates cron is not running. For information about the error, see our troubleshooting page.

This shows how to set up cron.

  • The cron jobs shown at the troubleshooting page are running and working. So that seems not to be the problem... – twf-thimo Oct 24 '16 at 16:58
  • 1
    The errors don't indicate that whatsoever – Timothy Frew Jan 1 '17 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.