2

I am using Varnish cache on Magento 2.1, and I need to disable the cache for upgrading purpose.

I go to System > Tools > Cache Management, and select all the cache types, and choose "disable" and submit.

But I this error error:

Deployment config file env.php is not writable.

I tried to chmod app/etc/env.php and app/etc/config.php to writable (777), but still can't disable the cache.

Any idea why this is happening?

thanks!

2

Use a Command prompt with php bin/magento cache:disable

  • Yes, this is the workable way even if env.php still shows the above error – greentealeaf Oct 24 '16 at 8:42
  • it got resolved when You additionally set the write permission for app/etc/config.php apart from the env.php file – Harendra Prajapati Oct 24 '16 at 8:55
  • does it work for you? as illustrated in the question, I tried to chmod app/etc/env.php and app/etc/config.php to writable (777), but still can't disable the cache. – greentealeaf Oct 24 '16 at 9:48
  • Also make sure env.php and config.php are owned by the Magento file system owner, not by the web server user. (Both files should be owned by <magento file system owner>:<web server group>) – Steve Johnson Oct 24 '16 at 16:35
  • for apache, should it be www-data:www-data? – greentealeaf Oct 25 '16 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.