0

i have recently upgraded to magento 1.8.1 and since that point if i have my SSL enabled on the front end my customers cant proceed to the checkout from the cart. When the button is clicked the cart just gets reloaded.

After doing some research some people said it was suhosin php causing the problem. Well i had that disabled by my hosting providers, cleared store and browser cache etc but yet the problem stilll persists.

has anyone else had this problem?

If so how did you solve it?

Thanks

EDIT

When i enter the site using https:// and SSL is turned ON in front end, i can proceed to checkout fine from the cart.

When i enter the site from http:// and SSL is turned OFF i can proceed to checkout fine from the cart.

The problem is occurring when i enter the site via http:// and have SSL turned ON in front end. SO it seems that data isn't being transferred from http and https:// or something

6
  • Is there something in magento/var/log files? Commented Jan 31, 2014 at 16:45
  • I dont seem to have a logs directory in var?
    – Tom Burman
    Commented Jan 31, 2014 at 17:04
  • Have you enabled ini_set('display_errors', 1) and developers mode in index.php? Commented Jan 31, 2014 at 17:07
  • no i have not, i do know about the ini_set method but wasnt sure how to do it in magento?
    – Tom Burman
    Commented Jan 31, 2014 at 17:10
  • just go to index php. Uncomment line ini_set('display_errors', 1); and comment if statement around Mage::setIsDeveloperMode(true);. Commented Jan 31, 2014 at 17:11

1 Answer 1

1

I can explain you that.

When SSL is turned ON magento thinks that your site is available only from https(and this is logically). So if customer click to "Checkout" button on http site it redirects you to https checkout page but browser permission does not allow to access http domain cookies data from https domain. The only way to fix that configure your server to redirect customer to https domain when he tries to access http one.

Hope that will help you.

2
  • Would this be something i have to contact my server providers about or something i can do myself? i have access to cpanel and that is all. Thanks
    – Tom Burman
    Commented Jan 31, 2014 at 21:58
  • What is the value of Base URL in System->Configuration->Web->Secure? Does it contain https? Commented Feb 1, 2014 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.