I have an entry of 54K users in Customers. In Database customer_entity table it's showing count.

It's working an hour before. Suddenly it's not displaying in Admin Customer Listing. Trying to search as well. Still not displaying record.

I have cleared cache as well. No errors in Log

What's the reason behind this issue or why it occurs? Because Magento behaves strangely.

  • Is there any customer from customer_grid_flat table? – Khoa TruongDinh Oct 21 '16 at 6:16
  • customer_grid_flat table is Blank :( No records. It's 0 – Jackson Oct 21 '16 at 6:18
  • Tried to reindex database? – Khoa TruongDinh Oct 21 '16 at 6:18
  • Let me do that static:content-deploy is not going to affect right? – Jackson Oct 21 '16 at 6:19
  • php bin/magento indexer:reindex – Khoa TruongDinh Oct 21 '16 at 6:20

Reset your databse: Magento 2: Not showing customers in backend grid

update indexer_state set status = 'invalid' where status != 'valid';


We should use

php bin/magento indexer:reset customer_grid

Possible errors:

--Disable safe mode

update magento.indexer_state set status = 'invalid' where status != 'valid' Error Code: 1175. You are using safe update mode and you tried to update a table without a WHERE that uses a KEY column To disable safe mode, toggle the option in Preferences -> SQL Editor and reconnect. 0.000 sec

Reference here: https://stackoverflow.com/questions/11448068/mysql-error-code-1175-during-update-in-mysql-workbench

--Not able to run php bin/magento indexer:reindex customer_grid

Customer Grid index is locked by another reindex process. Skipping.

show processlist; 
kill "id number";

Or, we can restart mysql server.

--A large number of database - php -dmemory_limit=512M

If you have a large number of database, run the command with

php -dmemory_limit=512M bin/magento indexer:reindex customer_grid

Or should increase the memory_limit ~ 512M in php.ini

| improve this answer | |
  • 1
    Should be: php bin/magento indexer:reset customer_grid instead of php bin/magento indexer:rest customer_grid – KyleBunga Apr 8 '19 at 16:58

I will NOT recommend to mess with Magento database directly.

Try this:

php bin/magento indexer:reset customer_grid
php bin/magento indexer:reindex customer_grid
| improve this answer | |
  • Thanks @alta-works, your solution is much easy and straight forward. – Mohit Kumar Arora Sep 6 '17 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.