0

I am unable to login in magento admin panel. Magento ver. 1.9.2.4. Reason is in every minute its calling this:

Error : {ajaxExpired: 1,…} ajaxExpired : 1 ajaxRedirect : "https://www.gleitsichtbrille.de/index.php/ag_supervista/index/login/key/dc32322811d123b75356a152194991d0/"

I have followed below steps to solve this error:

  1. Clear browser cache, history,etc
  2. Delete cache folder from var.
  3. checked with below code to comment it in app\code\core\Mage\Core\Model\Session\Abstract\Varien.php and remove cache:

    // session cookie params
    /*$cookieParams = array(
        'lifetime' => $cookie->getLifetime(),
        'path'     => $cookie->getPath(),
        'domain'   => $cookie->getConfigDomain(),
        'secure'   => $cookie->isSecure(),
        'httponly' => $cookie->getHttponly()
    );*/
    
  4. Set Permission 777 to cache and session folder.

  5. Set web configuration "Use HTTP Only" to "No".

  • Site is in aws. If we remove load balancer then it is working fine. – Dev Oct 21 '16 at 5:33
  • Is your customer accounts working as expected? customers are able to login and browse with in their account? – Nidheesh Oct 21 '16 at 6:16
  • There is no myaccount option in the site.This site CMS only. Frontend site is working fine. There is an issue wit admin panel only. – Dev Oct 21 '16 at 7:00
  • Everything else working? add to cart checkout etc? – Nidheesh Oct 21 '16 at 7:01
  • This site CMS only. Frontend site is working fine. There is an issue with admin panel only. Once login its now redirecting to black page. If I enter manually in the url, page is loading. It is not working when click event is fire. – Dev Oct 21 '16 at 7:03
0

My issue is solved now!!!

I have deleted Application Load Balancer from AWS EC2 and followed below steps to create Classic Load Balancer with cookies 3600 as same was in my magento site.

  • Open the Amazon EC2 console at https://console.aws.amazon.com/ec2/.

  • On the navigation pane, under LOAD BALANCING, choose Target Groups.

  • Select the target group.

  • On the Description tab, choose Edit attributes.

  • On the Edit attributes page, do the following:

  • Select Enable load balancer generated cookie stickiness.

  • For Stickiness duration, specify a value between 1 second and 7 days.

  • Choose Save.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.