2

I've added this to default.xml, which partially works to remove the zoom feature

<head>
    <remove src="Magento_Catalog::js/jquery.zoom.min.js" />
</head>

However, a magnifying glass still appears above the product image on the product detail page.

I've noticed sections in view.xml, specifically vendor/magento/theme-frontend-blank/etc/view.xml which parameterize a magnifier, one of these seems to toggle it on or off -

<var name="magnifier">
   <var name="enabled">false</var> <!-- Turn on/off magnifier (true/false) -->
</var>

This is set to false in my theme's view.xml file as well. Any idea what else I need to do to completely remove the magnification / zoom feature in Magento2?

2
  • Please look in to this file vendor\magento\module-catalog\view\frontend\templates\product\view\gallery.phtml Magnifier JS as well
    – Jackson
    Oct 21 '16 at 1:38
  • 1
    Add view.xml complete path for more information. Oct 21 '16 at 5:14
9

Having experimented with more settings in the view.xml file, it seems changing

<var name="allowfullscreen">true</var>

to

<var name="allowfullscreen">false</var>

solved the problem.

7
  • Unfortunately this did not work for me.
    – stephen
    Nov 17 '16 at 15:00
  • Sorry to hear Stevie. Let us know your solution if you figure it out for your setup. Nov 17 '16 at 15:11
  • Your answer is incorrect as it does not actually remove the product zoom on hover. It removes the lightbox.
    – stephen
    Nov 23 '16 at 10:12
  • Hi Stevie, perhaps the lightbox and magnifying glass are something different? When I made this change the magnifying glass went away... And as I said earlier, if you want to offer up a better solution, feel free to do so... Nov 23 '16 at 18:45
  • Your method is what I used to enable the magnifier in the first place. StevieG might have another extension for zooming. Mar 2 '18 at 10:29
1

One way we disabled this was to add following CSS ;

 .zoomImg {
    display: none !important;
    visibility: hidden;
}
1
  • its working but, how we can fix with gallery widget?
    – Sourav
    Dec 11 '20 at 12:26
0

Disable product magnification / zoom in Magento 2 set false enabled var magnifier in view.xml file of theme run static-content:deploy and cache:flush cmd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.