0

I am trying to install Magento 2 on my server. My Server configuration are:

  1. 6gb Ram
  2. Mysql Version 5.6
  3. Php Version 5.6.26
  4. VPS server
  5. ISPconfig 3 admin panel

Everything is okay according to the Magento requirement, but I'm not able to install Magento 2 there. Every time I get the following error:

One thing I have same PHP version but in PHP configuration loaded PHP path and Php CLI loaded PHP configuration path is different.

Can anybody help me to get out this issue?

The Error Show me is:

PHP Version Check Your PHP version is . The required PHP version is . Hide detail Download and install PHP from www.php.net using this PHP Documentation. For additional assistance, contact your hosting provider.

PHP Extensions Check missing PHP extensions. Hide detail The best way to resolve this is to install the correct missing extensions. >The exact fix depends on our server, your host, and other system variables. Our PHP extension help can get you started. For additional assistance, contact your hosting provider.

  • Do you have multiple versions of php installed? what does php -v from the command line show? – Kristof at Fooman Feb 4 '17 at 7:48
  • yes, i have multiple PHP version on the site. But php -v show 5.6.23.xxx – Shuvankar Paul Apr 25 '17 at 10:58
0

In this case I think your issue is running two different version of php, one in your web server and one in your command line. This is a common issue when installing Magento 2 locally on something like MAMP.

When you say "your server" you don't specify what server it is that you are trying to install on, so it isn't possible to give you a clear solution for your problem.

If you are having issues with not having the right php modules installed on your server, you would be able to see that in the warning message's more info section. If that is the case, you should be able to find those modules and install them per their instructions.

  • 1
    Thanks, for the response, but i think i found the solution, just open you composer.json in root directory and then on ` "config": { "use-include-path": true } ` add the follow line : <code> "disable-tls":true </code> So now the text will be, <code> "config": { "use-include-path": true "disable-tls":true }, </code> this is because by default Magento has SSL enabled. – Shuvankar Paul Apr 25 '17 at 10:59
  • Thanks, for the response, but i think i found the solution, just open you composer.json in root directory and then on "config": { "use-include-path": true } add the following line: "disable-tls":true So now the text will be, "config": { "use-include-path": true "disable-tls":true }, this is because by default Magento has SSL enabled. – Shuvankar Paul Apr 25 '17 at 11:05
  • Ah, that makes sense. if you have the time, post this as an answer so it will be easier for other people with the same problem to find it. – circlesix Apr 25 '17 at 15:40
0

I have found a solution for this. This problem is actually for the SSL issue.

By Default Magento 2 consider you have run your store on secure protocol. If server not run over secure protocol then you need to follow the step to run your site on your server under domain.

  • Go to the root directory of Magento 2 file system.
  • Then open the composer.json file

Around line number 43, you will find following code depending Magento 2 subversion.The following two type of code can be found.

Type 1- With disable-tls parameter like bellow

"config": {
  "use-include-path": true 
  "disable-tls":false
},

Type 2- Without disable-tls parameter

"config": {
    "use-include-path": true,
},

Note : Type 2 is used on recent Magento 2 Subversion.

Solution:

On Both cases, the config key's parameter final code will be.

"config": {
    "use-include-path": true,
    "disable-tls":true
},

I mean in first case change "disable-tls":false to "disable-tls":true

and on second case add the line "disable-tls":false

Thanks, Everybody.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.