1

When I complete an order, I configured Magento to send an e-mail to the buyer. But no e-mail are sent…

In the “sales email” page (in the system settings), I enabled all e-mails. And in the “system config” page, serveur is “localhost” and port “25”.

I use CentOS.

Can you help me ?

6
  • are you sure that the server can send e-mails?
    – Marius
    Jan 31, 2014 at 8:38
  • I have no idea... Can you tell me how to check that ? It's host on a dedicated server from OVH. With CentOS 6.5 and Plesk... Thanks.
    – BnJ
    Jan 31, 2014 at 8:42
  • Try to run in command line telnet smtp.localhost 25 Jan 31, 2014 at 8:46
  • Sendmail is not installed, but there is Postfix.
    – BnJ
    Jan 31, 2014 at 9:10

4 Answers 4

3

Are you sure that email is not sent? Maybe it's in SPAM or something. Try to send email by simple PHP script:

<?php
 $to = "[email protected]";
 $subject = "Hi!";
 $body = "Hi,\n\nHow are you?";
 if (mail($to, $subject, $body)) {
   echo("<p>Email successfully sent!</p>");
  } else {
   echo("<p>Email delivery failed…</p>");
  }

If it don't work configure postfix/smtp/exim server.

3
  • Your script show me this : "Email successfully sent!", but I receive no email (and yes I changed de email adress).
    – BnJ
    Jan 31, 2014 at 11:45
  • Did you check in spam? Check smts server log's
    – kuba_ceg
    Jan 31, 2014 at 13:45
  • 1
    Most mail failures blamed on Magento are actually Server Admin 101 setup problems. The rest are because the old Port 25 MX pump'n dump is viewed as a spam source and the remote server is rejecting unauthenticated, plaintext transmitted email from a server that fails to use mechanisms like SPF or DKIM and reverse lookup records. Jan 31, 2014 at 15:43
3

Most mail failures blamed on Magento are actually Server Admin 101 setup problems and outside the venue of this section of Stack Exchange. It sounds like you will need to set up Postfix. At one time there was a Wiki over on MagentoCommerce.com giving instruction on how to do this, but it seems to have eBayvaporated.

The rest are because the old Port 25 MX pump'n dump is viewed as a spam source and the remote server is rejecting unauthenticated, plaintext transmitted email from a server that fails to use mechanisms like SPF or DKIM and reverse lookup records.

Get yourself an email service provider like Rackspace and an authorized SMTP module like Ashley Shroeder's SMTP Pro which allows you to send SSL/TLS protected email to an authenticated SMTP server. Check with your hosting provider to see if they do authenticated, secured mail transport if you don't want to use an external email service provider, some are getting smart about extending the value of their services. Also set up SPF records in your DNS.

Failing to set up an authenticated, secured mail service can also result in email scoring that dumps all your transactional emails into the corporate spam quarantine, people's personal quarantine and/or local email client spam folders.

0

Magento fails to send email to some domain as i had experience in past. in order to fix that i had used Smtp pro extension which fixes many of the issues as it uses smtp protocol, follow below link for that

Dowload from here

0

I had this issue after moving to a new server and it turned out to be the most simple of fixes.

My clients email service was hosted on their local server. My new server host uses a stand alone DNS server as opposed to DNS being handled by WHM/Cpanel on the server at my old host. Although I had the stand alone DNS server configured correctly, the MX record under CPanel was still set to 'automatic' and was therefore targeting LOCAL.

I changed the setting to 'REMOTE' (obviously making sure DNS settings were correct!) and immediately all emails started sending correctly.

I watched the core_email_queue & core_email_queue_recipients tables and monitored cron in AOE_Scheduler which appeared to worked except core_email_queue_recipients did not clear.

I configured the small extension found HERE to clear the core_email_queue_recipients table when the core_email_queue cron runs which resolved that issue.

All works perfectly now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.