0

After having some issues with 8788 patch. I cant seem to revert 8788v1. So I was wondering if the following was possible based on

  • Revert SUPEE-8788 v1/

The process that I have followed using version control is to copy the patch into the root directory. Run the Patch. Then once it has been installed remove the patch file from the root directory. Then merge and commit etc. So how do I then revert this patch? I have tried placing the same file again in the root directory and running sh patch-file-name.sh -R But I am given a lot of errors and it does not revert the patch.

I also have a question I updated a site to 1.9.2.4 but I have installed v2 of the 8788 patch but Mage Report is saying that it is not patched. Could I simply install patch 3941 as 1533 is not installed and 8788 v1 is not installed Would this work?

How do I do this:

  • Revert SUPEE-8788 v1/
  • Revert SUPEE-1533 (if installed)

Because the patch files are not in the root of the Magento website.

Also if I have installed 8788v1 and installed 3941 and cant revert 8788v1 can I just install 8788v2?

The other issue is that it says to install 3941 but it is only available for versions 1.8 - 1.9 so if the site is greater than 1.9.0.1 or lower than 1.8 do I install it?

Thanks

1

The process that I have followed using version control is to copy the patch into the root directory. Run the Patch. Then once it has been installed remove the patch file from the root directory. Then merge and commit etc. So how do I then revert this patch?

Just revert the commit. With Git this would be git revert HEAD

I also have a question I updated a site to 1.9.2.4 but I have installed v2 of the 8788 patch but Mage Report is saying that it is not patched. Could I simply install patch 3941 as 1533 is not installed and 8788 v1 is not installed Would this work?

If applying 8788v2 was successful, i.e. the files have been changed, you don't need to revert or re-apply anything. Magento 1.9.2.4 already contains all previous patches.

The message from Magereport is either a false positive or you have overridden / rewritten classes that have been patched. Look for these and change them accordingly.

The other issue is that it says to install 3941 but it is only available for versions 1.8 - 1.9 so if the site is greater than 1.9.0.1 or lower than 1.8 do I install it?

It's possible to apply the patch for 1.8 on lower versions, at least for 1.7 and this is what you need to do.

  • Hello, I have come across another issue. I have a site on 1.9.2.1 however 1533 is installed SUPEE-1533_EE_1.12_v1.patch but I cannot find the original file. As the one available on the Magento Download is SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh it is a completely different version. As it says REVERTED when I have ran the script. But then I cannot apply 3941 it just fails. So I have tried applying 8788v2 and that also fails. Is there a way I can revert 1533 another way? I have even tried applying 8788v2 on its own, that also fails. Thanks – Rob B Oct 24 '16 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.