0

@EDIT: it finally worked. I just needed to clear Magento's cache. In case you need to do so, go to /var/cache and delete everything there, and then start again.

I installed Magento 2 with WAMP server on Windows 10. I installed it with sample data, and I can properly access the example page on http: //localhost/magento. But when I try to access the backend with the admin url, I get the message "Cannot access the page" from the browser (no matter which). On installing, th url for admin was set to https: //localhost/magento/admin_abcd1234

As it didn't work, I thought of enabling ssl_module on wamp, but it didn't work and Apache stopped working. So I unenabled it again.

After that, I went to phpMyAdmin, magento databse, core_config_data table, and changed web/secure/use_in_adminhtml value to 0. I also tried NULL. I still could not access the admin page. I have read several posts in forums and still cannot figure out what is happening. I checked mod_rewrite in Apache too, but I didn't see any effect. I am a bit new in using servers, PHP and MySQL.

If I access http: //localhost/magento/admin_abcd1234 the browser changes to https: //localhost/magento/admin_abcd1234 after few seconds.

0

Is it possible that you have entered a https link as the secure base URL and enabled the option to use secure URL in admin panel? Local host can't run https. You can change this in the database table: core_config and search path like %base_url%

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.